summaryrefslogtreecommitdiffstats
path: root/package/base-files
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2009-03-08 00:21:25 +0000
committerJo-Philipp Wich <jow@openwrt.org>2009-03-08 00:21:25 +0000
commit8a6acee2e2c469eb4db82e1b96d79b63c4b07658 (patch)
treee82a543e0061ad9d6ed238e6f5bfa70e93e328dc /package/base-files
parent5d57dbaebac08368eb84f3ece9a3ce845d86bdfd (diff)
downloadmaster-31e0f0ae-8a6acee2e2c469eb4db82e1b96d79b63c4b07658.tar.gz
master-31e0f0ae-8a6acee2e2c469eb4db82e1b96d79b63c4b07658.tar.bz2
master-31e0f0ae-8a6acee2e2c469eb4db82e1b96d79b63c4b07658.zip
sysupgrade: install /bin/sleep into ramdisk too and add completition notice (#4747)
SVN-Revision: 14784
Diffstat (limited to 'package/base-files')
-rw-r--r--package/base-files/Makefile4
-rw-r--r--package/base-files/files/lib/upgrade/common.sh3
2 files changed, 4 insertions, 3 deletions
diff --git a/package/base-files/Makefile b/package/base-files/Makefile
index 437952d72f..33e8237819 100644
--- a/package/base-files/Makefile
+++ b/package/base-files/Makefile
@@ -1,5 +1,5 @@
#
-# Copyright (C) 2007 OpenWrt.org
+# Copyright (C) 2007-2009 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/kernel.mk
PKG_NAME:=base-files
-PKG_RELEASE:=15
+PKG_RELEASE:=16
PKG_FILE_DEPEND:=$(PLATFORM_DIR)/ $(GENERIC_PLATFORM_DIR)/base-files/
diff --git a/package/base-files/files/lib/upgrade/common.sh b/package/base-files/files/lib/upgrade/common.sh
index cf8977a5f2..d4fb04ba97 100644
--- a/package/base-files/files/lib/upgrade/common.sh
+++ b/package/base-files/files/lib/upgrade/common.sh
@@ -45,7 +45,7 @@ pivot() { # <new_root> <old_root>
}
run_ramfs() { # <command> [...]
- install_bin /bin/busybox /bin/ash /bin/sh /bin/mount /bin/umount /sbin/pivot_root /usr/bin/wget /sbin/reboot /bin/sync /bin/dd /bin/grep /bin/cp /bin/mv /bin/tar /usr/bin/md5sum "/usr/bin/[" /bin/vi /bin/ls /bin/cat /usr/bin/awk /usr/bin/hexdump
+ install_bin /bin/busybox /bin/ash /bin/sh /bin/mount /bin/umount /sbin/pivot_root /usr/bin/wget /sbin/reboot /bin/sync /bin/dd /bin/grep /bin/cp /bin/mv /bin/tar /usr/bin/md5sum "/usr/bin/[" /bin/vi /bin/ls /bin/cat /usr/bin/awk /usr/bin/hexdump /bin/sleep
install_bin /sbin/mtd
for file in $RAMFS_COPY_BIN; do
install_bin $file
@@ -160,6 +160,7 @@ do_upgrade() {
jffs2_copy_config
fi
}
+ v "Upgrade completed"
[ -n "$DELAY" ] && sleep "$DELAY"
ask_bool 1 "Reboot" && reboot
}