summaryrefslogtreecommitdiffstats
path: root/package/base-files
diff options
context:
space:
mode:
authorHamish Guthrie <hcg@openwrt.org>2009-05-04 12:39:21 +0000
committerHamish Guthrie <hcg@openwrt.org>2009-05-04 12:39:21 +0000
commit42e35d0a95e1662261ab21c18845377fc99000da (patch)
tree211b35002ae4ac14b00e630d726b3a2a52b67380 /package/base-files
parent0f12854d021bae307b61da13597995fe4fb7b37d (diff)
downloadmaster-31e0f0ae-42e35d0a95e1662261ab21c18845377fc99000da.tar.gz
master-31e0f0ae-42e35d0a95e1662261ab21c18845377fc99000da.tar.bz2
master-31e0f0ae-42e35d0a95e1662261ab21c18845377fc99000da.zip
base-files: Add additional base-files search paths
SVN-Revision: 15583
Diffstat (limited to 'package/base-files')
-rw-r--r--package/base-files/Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/package/base-files/Makefile b/package/base-files/Makefile
index 5578c90da8..c47a0f8ba4 100644
--- a/package/base-files/Makefile
+++ b/package/base-files/Makefile
@@ -148,12 +148,18 @@ define Package/base-files$(TARGET)/install
if [ -d $(PLATFORM_DIR)/base-files-$(PROFILE)/. ]; then \
$(CP) $(PLATFORM_DIR)/base-files-$(PROFILE)/* $(1)/; \
fi
+ if [ -d $(PLATFORM_DIR)/$(PROFILE)/base-files/. ]; then \
+ $(CP) $(PLATFORM_DIR)/$(PROFILE)/base-files/* $(1)/; \
+ fi
$(if $(filter-out $(PLATFORM_DIR),$(PLATFORM_SUBDIR)), \
if [ -d $(PLATFORM_SUBDIR)/base-files/. ]; then \
$(CP) $(PLATFORM_SUBDIR)/base-files/* $(1)/; \
fi; \
if [ -d $(PLATFORM_SUBDIR)/base-files-$(PROFILE)/. ]; then \
$(CP) $(PLATFORM_SUBDIR)/base-files-$(PROFILE)/* $(1)/; \
+ fi; \
+ if [ -d $(PLATFORM_SUBDIR)/$(PROFILE)/base-files/. ]; then \
+ $(CP) $(PLATFORM_SUBDIR)/$(PROFILE)/base-files/* $(1)/; \
fi \
)
# Form valid /etc/shadow entries, by copying the user:pw pairs