summaryrefslogtreecommitdiffstats
path: root/package/base-files
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2011-06-23 11:46:24 +0000
committerJo-Philipp Wich <jow@openwrt.org>2011-06-23 11:46:24 +0000
commit28fbd7470d1c35edf1de93a0ac26027cf47c724c (patch)
treead54f594307f6173691fd3e2eb1fbf3bf366b54e /package/base-files
parenta56dab661a115e6cc9f4361d5ff831d998cb9f00 (diff)
downloadmaster-31e0f0ae-28fbd7470d1c35edf1de93a0ac26027cf47c724c.tar.gz
master-31e0f0ae-28fbd7470d1c35edf1de93a0ac26027cf47c724c.tar.bz2
master-31e0f0ae-28fbd7470d1c35edf1de93a0ac26027cf47c724c.zip
add gfortran compiler support (#9600, patch from Xiangfu Liu via Qi hardware)
SVN-Revision: 27262
Diffstat (limited to 'package/base-files')
-rw-r--r--package/base-files/Makefile40
1 files changed, 40 insertions, 0 deletions
diff --git a/package/base-files/Makefile b/package/base-files/Makefile
index 23bd51a0bd..ca4a689623 100644
--- a/package/base-files/Makefile
+++ b/package/base-files/Makefile
@@ -247,6 +247,32 @@ define Package/librt/config
endef
+define Package/libgfortran
+$(call Package/gcc/Default)
+ TITLE:=GFortran support library
+ DEPENDS+=@!(TARGET_avr32||TARGET_coldfire) @INSTALL_GFORTRAN
+endef
+
+define Package/libgfortran/config
+ menu "Configuration"
+ depends EXTERNAL_TOOLCHAIN && PACKAGE_libgfortran
+
+ config LIBGFORTRAN_ROOT_DIR
+ string
+ prompt "libgfortran shared library base directory"
+ depends EXTERNAL_TOOLCHAIN && PACKAGE_libgfortran
+ default TOOLCHAIN_ROOT if !NATIVE_TOOLCHAIN
+ default "/" if NATIVE_TOOLCHAIN
+
+ config LIBGFORTRAN_FILE_SPEC
+ string
+ prompt "libgfortran shared library files (use wildcards)"
+ depends EXTERNAL_TOOLCHAIN && PACKAGE_libgfortran
+ default "./usr/lib/libgfortran.so.*"
+
+ endmenu
+endef
+
define Package/ldd
$(call Package/libc/Default)
SECTION:=utils
@@ -466,6 +492,11 @@ ifeq ($(CONFIG_EXTERNAL_TOOLCHAIN),)
$(CP) $(PKG_BUILD_DIR)/libgcc_s.so.* $(1)/lib/
endef
+ define Package/libgfortran/install
+ $(INSTALL_DIR) $(1)/usr/lib
+ $(CP) $(TOOLCHAIN_DIR)/lib/libgfortran.so.* $(1)/usr/lib/
+ endef
+
define Package/libssp/install
$(INSTALL_DIR) $(1)/lib
$(CP) $(TOOLCHAIN_DIR)/lib/libssp.so.* $(1)/lib/
@@ -581,6 +612,14 @@ else
exit 0
endef
+ define Package/libgfortran/install
+ for file in $(call qstrip,$(CONFIG_LIBGFORTRAN_FILE_SPEC)); do \
+ dir=`dirname $$$$file` ; \
+ $(INSTALL_DIR) $(1)/$$$$dir ; \
+ $(CP) $(call qstrip,$(CONFIG_LIBGFORTRAN_ROOT_DIR))/$$$$file $(1)/$$$$dir/ ; \
+ done
+ endef
+
define Package/libssp/install
for file in $(call qstrip,$(CONFIG_LIBSSP_FILE_SPEC)); do \
dir=`dirname $$$$file` ; \
@@ -657,5 +696,6 @@ $(eval $(call BuildPackage,libssp))
$(eval $(call BuildPackage,libstdcpp))
$(eval $(call BuildPackage,libpthread))
$(eval $(call BuildPackage,librt))
+$(eval $(call BuildPackage,libgfortran))
$(eval $(call BuildPackage,ldd))
$(eval $(call BuildPackage,ldconfig))