summaryrefslogtreecommitdiffstats
path: root/package/base-files
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2011-11-17 09:40:06 +0000
committerJo-Philipp Wich <jow@openwrt.org>2011-11-17 09:40:06 +0000
commit010e58d2092b6c8637a84eba7d9d1d43dfd71b39 (patch)
treee7aebf89fc025fffe94c32ec0724a7baf91b45cd /package/base-files
parent33443d2a8c3a202311751c6de72d7815d22f79f7 (diff)
downloadmaster-31e0f0ae-010e58d2092b6c8637a84eba7d9d1d43dfd71b39.tar.gz
master-31e0f0ae-010e58d2092b6c8637a84eba7d9d1d43dfd71b39.tar.bz2
master-31e0f0ae-010e58d2092b6c8637a84eba7d9d1d43dfd71b39.zip
base-files: another empty password check fix (#10440)
SVN-Revision: 29208
Diffstat (limited to 'package/base-files')
-rw-r--r--package/base-files/Makefile2
-rwxr-xr-xpackage/base-files/files/bin/login.sh2
2 files changed, 2 insertions, 2 deletions
diff --git a/package/base-files/Makefile b/package/base-files/Makefile
index b93d2cb402..9b3745ba98 100644
--- a/package/base-files/Makefile
+++ b/package/base-files/Makefile
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/kernel.mk
PKG_NAME:=base-files
-PKG_RELEASE:=96
+PKG_RELEASE:=97
PKG_FILE_DEPENDS:=$(PLATFORM_DIR)/ $(GENERIC_PLATFORM_DIR)/base-files/
PKG_BUILD_DEPENDS:=opkg/host
diff --git a/package/base-files/files/bin/login.sh b/package/base-files/files/bin/login.sh
index 6682b022ba..04b3fe2502 100755
--- a/package/base-files/files/bin/login.sh
+++ b/package/base-files/files/bin/login.sh
@@ -1,7 +1,7 @@
#!/bin/sh
# Copyright (C) 2006-2011 OpenWrt.org
-if ( ! grep -qs '^root::' /etc/shadow || \
+if ( ! grep -qs '^root:[!x]\?:' /etc/shadow || \
! grep -qs '^root:[!x]\?:' /etc/passwd ) && \
[ -z "$FAILSAFE" ]
then