summaryrefslogtreecommitdiffstats
path: root/package/base-files/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2009-08-29 03:51:43 +0000
committerFelix Fietkau <nbd@openwrt.org>2009-08-29 03:51:43 +0000
commitfc5426e4bce52e2f0de597899718cf116205c8c0 (patch)
treef1d82360741d83455dd8c8d0fdabf3147376384f /package/base-files/Makefile
parent0464fa7f2ab676a0f4ac89723e8c9e11062cc630 (diff)
downloadmaster-31e0f0ae-fc5426e4bce52e2f0de597899718cf116205c8c0.tar.gz
master-31e0f0ae-fc5426e4bce52e2f0de597899718cf116205c8c0.tar.bz2
master-31e0f0ae-fc5426e4bce52e2f0de597899718cf116205c8c0.zip
allow mklibs.py to optimize libgcc_s.so.1
SVN-Revision: 17437
Diffstat (limited to 'package/base-files/Makefile')
-rw-r--r--package/base-files/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/package/base-files/Makefile b/package/base-files/Makefile
index 92257d8011..e6cbb21617 100644
--- a/package/base-files/Makefile
+++ b/package/base-files/Makefile
@@ -247,6 +247,7 @@ endef
define Package/libc/install_lib
$(CP) $(filter-out %/libdl_pic.a,$(wildcard $(TOOLCHAIN_DIR)/usr/lib/lib*.a)) $(1)/lib/
+ $(CP) $(TOOLCHAIN_DIR)/usr/lib/gcc/*/*/libgcc.a $(1)/lib/libgcc_s_pic.a
endef
define Package/libpthread/install