summaryrefslogtreecommitdiffstats
path: root/package/base-files/Makefile
diff options
context:
space:
mode:
authorDaniel Dickinson <lede@daniel.thecshore.com>2016-05-18 09:07:30 -0400
committerJo-Philipp Wich <jo@mein.io>2016-06-24 13:52:53 +0200
commitf954f4337b85bd8d8ad6a589bc63edf48f777ee6 (patch)
tree8158e3d8584d80f4960da16be581503c6ca07d54 /package/base-files/Makefile
parent59e98b27c93d282edb62fad756fd1c1e587c067f (diff)
downloadmaster-31e0f0ae-f954f4337b85bd8d8ad6a589bc63edf48f777ee6.tar.gz
master-31e0f0ae-f954f4337b85bd8d8ad6a589bc63edf48f777ee6.tar.bz2
master-31e0f0ae-f954f4337b85bd8d8ad6a589bc63edf48f777ee6.zip
base-files: Add standard os-release file
/etc/os-release is the standard distribution release information file, therefore add it (and image configuration options for fields not previously present in LEDE). Once it is deemed reasonable the non-standard openwrt_release, openwrt_version, and device_info files could be removed (that is with this patch we consider them deprecated in favour of the standard file). Signed-off-by: Daniel Dickinson <lede@daniel.thecshore.com>
Diffstat (limited to 'package/base-files/Makefile')
-rw-r--r--package/base-files/Makefile6
1 files changed, 4 insertions, 2 deletions
diff --git a/package/base-files/Makefile b/package/base-files/Makefile
index e51d65ac42..5cfb019080 100644
--- a/package/base-files/Makefile
+++ b/package/base-files/Makefile
@@ -138,11 +138,13 @@ define Package/base-files/install
$(VERSION_SED) \
$(1)/etc/banner \
- $(1)/etc/openwrt_version
+ $(1)/etc/openwrt_version \
+ $(1)/usr/lib/os-release
$(VERSION_SED_SCRIPT) \
$(1)/etc/openwrt_release \
- $(1)/etc/device_info
+ $(1)/etc/device_info \
+ $(1)/usr/lib/os-release
$(SED) "s#%PATH%#$(TARGET_INIT_PATH)#g" \
$(1)/sbin/hotplug-call \