summaryrefslogtreecommitdiffstats
path: root/package/base-files/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2009-10-20 06:57:19 +0000
committerFelix Fietkau <nbd@openwrt.org>2009-10-20 06:57:19 +0000
commitdc637ccdffa831bdfbeae9fece6b3545711f3149 (patch)
treeb609ca5293e08088bb88fb444740b0f412cc3d7c /package/base-files/Makefile
parentc724a69355c36ae803f328f3b99e552e4163713e (diff)
downloadmaster-31e0f0ae-dc637ccdffa831bdfbeae9fece6b3545711f3149.tar.gz
master-31e0f0ae-dc637ccdffa831bdfbeae9fece6b3545711f3149.tar.bz2
master-31e0f0ae-dc637ccdffa831bdfbeae9fece6b3545711f3149.zip
install the right version of libgcc along with its version map to fix relinking issues with mklibs, attempt to relink only if the version map is actually present
SVN-Revision: 18089
Diffstat (limited to 'package/base-files/Makefile')
-rw-r--r--package/base-files/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/package/base-files/Makefile b/package/base-files/Makefile
index b288c0dfce..4ee95aedfe 100644
--- a/package/base-files/Makefile
+++ b/package/base-files/Makefile
@@ -419,7 +419,10 @@ ifeq ($(CONFIG_EXTERNAL_TOOLCHAIN),)
define Package/libc/install_lib
$(CP) $(filter-out %/libdl_pic.a,$(wildcard $(TOOLCHAIN_DIR)/usr/lib/lib*.a)) $(1)/lib/
$(if $(wildcard $(TOOLCHAIN_DIR)/usr/lib/libc_so.a),$(CP) $(TOOLCHAIN_DIR)/usr/lib/libc_so.a $(1)/lib/libc_pic.a)
- $(CP) $(TOOLCHAIN_DIR)/usr/lib/gcc/*/*/libgcc.a $(1)/lib/libgcc_s_pic.a
+ $(if $(wildcard $(TOOLCHAIN_DIR)/usr/lib/gcc/*/*/libgcc.map), \
+ $(CP) $(TOOLCHAIN_DIR)/usr/lib/gcc/*/*/libgcc_pic.a $(1)/lib/libgcc_s_pic.a; \
+ $(CP) $(TOOLCHAIN_DIR)/usr/lib/gcc/*/*/libgcc.map $(1)/lib/libgcc_s_pic.map \
+ )
endef
define Package/libpthread/install