summaryrefslogtreecommitdiffstats
path: root/package/base-files/Makefile
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2016-02-08 14:28:50 +0000
committerJo-Philipp Wich <jow@openwrt.org>2016-02-08 14:28:50 +0000
commitcc289e0adb936bf350db2037544d7eb8e5b084c3 (patch)
tree5c91d58a6b92f380989cf4a68bd38b1807e308ea /package/base-files/Makefile
parenta8936bde1f21ce12ca85a0585eed0a2392180221 (diff)
downloadmaster-31e0f0ae-cc289e0adb936bf350db2037544d7eb8e5b084c3.tar.gz
master-31e0f0ae-cc289e0adb936bf350db2037544d7eb8e5b084c3.tar.bz2
master-31e0f0ae-cc289e0adb936bf350db2037544d7eb8e5b084c3.zip
base-files: honor CONFIG_TARGET_INIT_PATH
Signed-off-by: Jo-Philipp Wich <jow@openwrt.org> SVN-Revision: 48678
Diffstat (limited to 'package/base-files/Makefile')
-rw-r--r--package/base-files/Makefile14
1 files changed, 10 insertions, 4 deletions
diff --git a/package/base-files/Makefile b/package/base-files/Makefile
index bf32f6306a..4e3591a30b 100644
--- a/package/base-files/Makefile
+++ b/package/base-files/Makefile
@@ -1,5 +1,5 @@
#
-# Copyright (C) 2007-2015 OpenWrt.org
+# Copyright (C) 2007-2016 OpenWrt.org
# Copyright (C) 2010 Vertical Communications
#
# This is free software, licensed under the GNU General Public License v2.
@@ -11,17 +11,18 @@ include $(INCLUDE_DIR)/kernel.mk
include $(INCLUDE_DIR)/version.mk
PKG_NAME:=base-files
-PKG_RELEASE:=165
+PKG_RELEASE:=166
PKG_FILE_DEPENDS:=$(PLATFORM_DIR)/ $(GENERIC_PLATFORM_DIR)/base-files/
PKG_BUILD_DEPENDS:=usign/host
PKG_LICENSE:=GPL-2.0
-PKG_CONFIG_DEPENDS := CONFIG_SIGNED_PACKAGES
+PKG_CONFIG_DEPENDS := CONFIG_SIGNED_PACKAGES CONFIG_TARGET_INIT_PATH
include $(INCLUDE_DIR)/package.mk
ifneq ($(DUMP),1)
+ STAMP_CONFIGURED:=$(strip $(STAMP_CONFIGURED))_$(shell $(SH_FUNC) echo $(CONFIG_TARGET_INIT_PATH) | md5s)
TARGET:=-$(BOARD)
ifneq ($(wildcard $(PLATFORM_DIR)/base-files-$(PROFILE) $(PLATFORM_SUBDIR)/base-files-$(PROFILE)),)
TARGET:=$(TARGET)-$(PROFILE)
@@ -70,7 +71,7 @@ define ImageConfigOptions
mkdir -p $(1)/lib/preinit
echo 'pi_suppress_stderr="$(CONFIG_TARGET_PREINIT_SUPPRESS_STDERR)"' >$(1)/lib/preinit/00_preinit.conf
echo 'fs_failsafe_wait_timeout=$(if $(CONFIG_TARGET_PREINIT_TIMEOUT),$(CONFIG_TARGET_PREINIT_TIMEOUT),2)' >>$(1)/lib/preinit/00_preinit.conf
- echo 'pi_init_path=$(if $(CONFIG_TARGET_INIT_PATH),$(CONFIG_TARGET_INIT_PATH),"/usr/sbin:/usr/bin:/sbin:/bin")' >>$(1)/lib/preinit/00_preinit.conf
+ echo 'pi_init_path="$(TARGET_INIT_PATH)"' >>$(1)/lib/preinit/00_preinit.conf
echo 'pi_init_env=$(if $(CONFIG_TARGET_INIT_ENV),$(CONFIG_TARGET_INIT_ENV),"")' >>$(1)/lib/preinit/00_preinit.conf
echo 'pi_init_cmd=$(if $(CONFIG_TARGET_INIT_CMD),$(CONFIG_TARGET_INIT_CMD),"/sbin/init")' >>$(1)/lib/preinit/00_preinit.conf
echo 'pi_init_suppress_stderr="$(CONFIG_TARGET_INIT_SUPPRESS_STDERR)"' >>$(1)/lib/preinit/00_preinit.conf
@@ -141,6 +142,11 @@ define Package/base-files/install
$(1)/etc/openwrt_release \
$(1)/etc/device_info
+ $(SED) "s#%PATH%#$(TARGET_INIT_PATH)#g" \
+ $(1)/sbin/hotplug-call \
+ $(1)/etc/preinit \
+ $(1)/etc/profile
+
mkdir -p $(1)/CONTROL
mkdir -p $(1)/dev
mkdir -p $(1)/etc/crontabs