summaryrefslogtreecommitdiffstats
path: root/package/base-files/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-11-22 19:06:20 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-11-22 19:06:20 +0000
commitb61e77aeddfdcb222d26a0bb5fe3145f98b9b675 (patch)
tree7a11eda3c8a7b0d538eb4d77259c6e3229c751b6 /package/base-files/Makefile
parent576621f1e353339fe81ece6cff7e8bcd12cbc7b8 (diff)
downloadmaster-31e0f0ae-b61e77aeddfdcb222d26a0bb5fe3145f98b9b675.tar.gz
master-31e0f0ae-b61e77aeddfdcb222d26a0bb5fe3145f98b9b675.tar.bz2
master-31e0f0ae-b61e77aeddfdcb222d26a0bb5fe3145f98b9b675.zip
base-files: use the correct path in case of modified preinit options
If the user sets any preinit options in .config, the wrong path may get applied due to wrong default value in image-config.in and due to Makefile writing also the unchanged options into 00_preinit.conf Modify the default path in image-config.in to match the current default path set by r47080. Also modify the fall-back default in Makefile. Signed-off-by: Hannu Nyman <hannu.nyman@iki.fi> SVN-Revision: 47590
Diffstat (limited to 'package/base-files/Makefile')
-rw-r--r--package/base-files/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/package/base-files/Makefile b/package/base-files/Makefile
index 12f94898a7..b076dd9445 100644
--- a/package/base-files/Makefile
+++ b/package/base-files/Makefile
@@ -11,7 +11,7 @@ include $(INCLUDE_DIR)/kernel.mk
include $(INCLUDE_DIR)/version.mk
PKG_NAME:=base-files
-PKG_RELEASE:=161
+PKG_RELEASE:=162
PKG_FILE_DEPENDS:=$(PLATFORM_DIR)/ $(GENERIC_PLATFORM_DIR)/base-files/
PKG_BUILD_DEPENDS:=opkg/host usign/host
@@ -70,7 +70,7 @@ define ImageConfigOptions
mkdir -p $(1)/lib/preinit
echo 'pi_suppress_stderr="$(CONFIG_TARGET_PREINIT_SUPPRESS_STDERR)"' >$(1)/lib/preinit/00_preinit.conf
echo 'fs_failsafe_wait_timeout=$(if $(CONFIG_TARGET_PREINIT_TIMEOUT),$(CONFIG_TARGET_PREINIT_TIMEOUT),2)' >>$(1)/lib/preinit/00_preinit.conf
- echo 'pi_init_path=$(if $(CONFIG_TARGET_INIT_PATH),$(CONFIG_TARGET_INIT_PATH),"/bin:/sbin:/usr/bin:/usr/sbin")' >>$(1)/lib/preinit/00_preinit.conf
+ echo 'pi_init_path=$(if $(CONFIG_TARGET_INIT_PATH),$(CONFIG_TARGET_INIT_PATH),"/usr/sbin:/usr/bin:/sbin:/bin")' >>$(1)/lib/preinit/00_preinit.conf
echo 'pi_init_env=$(if $(CONFIG_TARGET_INIT_ENV),$(CONFIG_TARGET_INIT_ENV),"")' >>$(1)/lib/preinit/00_preinit.conf
echo 'pi_init_cmd=$(if $(CONFIG_TARGET_INIT_CMD),$(CONFIG_TARGET_INIT_CMD),"/sbin/init")' >>$(1)/lib/preinit/00_preinit.conf
echo 'pi_init_suppress_stderr="$(CONFIG_TARGET_INIT_SUPPRESS_STDERR)"' >>$(1)/lib/preinit/00_preinit.conf