summaryrefslogtreecommitdiffstats
path: root/package/base-files/Makefile
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2014-06-19 16:06:44 +0000
committerJo-Philipp Wich <jow@openwrt.org>2014-06-19 16:06:44 +0000
commit7eb721425e9655a5910f06d54672e2f639414c39 (patch)
tree5eb97518506b17081e01cab7987f135811ab2f17 /package/base-files/Makefile
parent1d9497292575b5c0ada993073b1f4b00bcf66e28 (diff)
downloadmaster-31e0f0ae-7eb721425e9655a5910f06d54672e2f639414c39.tar.gz
master-31e0f0ae-7eb721425e9655a5910f06d54672e2f639414c39.tar.bz2
master-31e0f0ae-7eb721425e9655a5910f06d54672e2f639414c39.zip
base-files: depend on jsonfilter and rewrite network.sh to use it
Switches /lib/functions/network.sh from jshn based json parsing to jsonfilter expression while keeping the existing api. Expensive methods like "network_find_wan" are up to 20x faster now. Signed-off-by: Jo-Philipp Wich <jow@openwrt.org> SVN-Revision: 41281
Diffstat (limited to 'package/base-files/Makefile')
-rw-r--r--package/base-files/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/package/base-files/Makefile b/package/base-files/Makefile
index eea9ecb8e0..a699084808 100644
--- a/package/base-files/Makefile
+++ b/package/base-files/Makefile
@@ -1,5 +1,5 @@
#
-# Copyright (C) 2007-2013 OpenWrt.org
+# Copyright (C) 2007-2014 OpenWrt.org
# Copyright (C) 2010 Vertical Communications
#
# This is free software, licensed under the GNU General Public License v2.
@@ -11,7 +11,7 @@ include $(INCLUDE_DIR)/version.mk
include $(INCLUDE_DIR)/kernel.mk
PKG_NAME:=base-files
-PKG_RELEASE:=153
+PKG_RELEASE:=154
PKG_FILE_DEPENDS:=$(PLATFORM_DIR)/ $(GENERIC_PLATFORM_DIR)/base-files/
PKG_BUILD_DEPENDS:=opkg/host
@@ -28,7 +28,7 @@ endif
define Package/base-files
SECTION:=base
CATEGORY:=Base system
- DEPENDS:=+netifd +libc +procd
+ DEPENDS:=+netifd +libc +procd +jsonfilter
TITLE:=Base filesystem for OpenWrt
URL:=http://openwrt.org/
VERSION:=$(PKG_RELEASE)-$(REVISION)