summaryrefslogtreecommitdiffstats
path: root/package/base-files/Makefile
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2012-06-05 18:02:00 +0000
committerJo-Philipp Wich <jow@openwrt.org>2012-06-05 18:02:00 +0000
commit6cdf25289c07141135e014eaeca742c2f39ff5c3 (patch)
tree1eb2a5764c2b4f3b6fd5cfd7212b1f3b9de74f38 /package/base-files/Makefile
parentf8655c017771e4eb10df4aa25649a4855662705d (diff)
downloadmaster-31e0f0ae-6cdf25289c07141135e014eaeca742c2f39ff5c3.tar.gz
master-31e0f0ae-6cdf25289c07141135e014eaeca742c2f39ff5c3.tar.bz2
master-31e0f0ae-6cdf25289c07141135e014eaeca742c2f39ff5c3.zip
base-files: add permission exceptions, do not clobber shadow permissions - based on patch by Mark Mentovai <mark@moxienet.com>
SVN-Revision: 32073
Diffstat (limited to 'package/base-files/Makefile')
-rw-r--r--package/base-files/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/package/base-files/Makefile b/package/base-files/Makefile
index 68c8e0233b..88167b788b 100644
--- a/package/base-files/Makefile
+++ b/package/base-files/Makefile
@@ -470,6 +470,10 @@ define Package/base-files/install
ln -sf /tmp $(1)/var
mkdir -p $(1)/etc
ln -sf /tmp/resolv.conf /tmp/fstab /tmp/TZ $(1)/etc/
+
+ chmod 0600 $(1)/etc/shadow
+ chmod 1777 $(1)/tmp
+
$(call ImageConfigOptions,$(1))
$(call Package/base-files/install-target,$(1))
for conffile in $(1)/etc/config/*; do \