summaryrefslogtreecommitdiffstats
path: root/package/base-files/Makefile
diff options
context:
space:
mode:
authorMathias Kresin <dev@kresin.me>2016-08-07 22:21:34 +0200
committerJohn Crispin <john@phrozen.org>2016-08-10 03:04:08 +0200
commit5fadd4397b395e5760f3c86751b711688efca6e9 (patch)
treecdccc301257d67b0c03fea0602db5ae6e211f21e /package/base-files/Makefile
parent14e0f057c8629ca658eb0e007c4f0e3f76b06f44 (diff)
downloadmaster-31e0f0ae-5fadd4397b395e5760f3c86751b711688efca6e9.tar.gz
master-31e0f0ae-5fadd4397b395e5760f3c86751b711688efca6e9.tar.bz2
master-31e0f0ae-5fadd4397b395e5760f3c86751b711688efca6e9.zip
preinit: use only the image config options
The pi_* variables and the fs_failsafe_wait_timeout variable are set by the CONFIG_TARGET_PREINIT_* config options. No need to maintain the same values twice. All other fs_ variables were never used. Signed-off-by: Mathias Kresin <dev@kresin.me>
Diffstat (limited to 'package/base-files/Makefile')
-rw-r--r--package/base-files/Makefile2
1 files changed, 0 insertions, 2 deletions
diff --git a/package/base-files/Makefile b/package/base-files/Makefile
index a32f345ea1..25fd9f2588 100644
--- a/package/base-files/Makefile
+++ b/package/base-files/Makefile
@@ -64,7 +64,6 @@ define Package/base-files/description
This package contains a base filesystem and system scripts for OpenWrt.
endef
-ifneq ($(CONFIG_PREINITOPT),)
define ImageConfigOptions
mkdir -p $(1)/lib/preinit
echo 'pi_suppress_stderr="$(CONFIG_TARGET_PREINIT_SUPPRESS_STDERR)"' >$(1)/lib/preinit/00_preinit.conf
@@ -81,7 +80,6 @@ define ImageConfigOptions
echo 'pi_preinit_no_failsafe_netmsg="$(CONFIG_TARGET_PREINIT_SUPPRESS_FAILSAFE_NETMSG)"' >>$(1)/lib/preinit/00_preinit.conf
echo 'pi_preinit_no_failsafe="$(CONFIG_TARGET_PREINIT_DISABLE_FAILSAFE)"' >>$(1)/lib/preinit/00_preinit.conf
endef
-endif
define Build/Prepare
mkdir -p $(PKG_BUILD_DIR)