summaryrefslogtreecommitdiffstats
path: root/package/base-files/Makefile
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2015-12-23 14:44:31 +0000
committerJohn Crispin <john@openwrt.org>2015-12-23 14:44:31 +0000
commit3f78186f765cf89c6795a0c1b4f404214fd3d6b0 (patch)
treedd9379e2bd8a272101726cd3507ea77d69ae5e84 /package/base-files/Makefile
parent7029ee5abea4ad43d6380f8c19319e48dc66aacb (diff)
downloadmaster-31e0f0ae-3f78186f765cf89c6795a0c1b4f404214fd3d6b0.tar.gz
master-31e0f0ae-3f78186f765cf89c6795a0c1b4f404214fd3d6b0.tar.bz2
master-31e0f0ae-3f78186f765cf89c6795a0c1b4f404214fd3d6b0.zip
base-files: allow timezone to be overriden by zonename (proper zoneinfo support)
Signed-off-by: Roman Yeryomin <roman@advem.lv> SVN-Revision: 47980
Diffstat (limited to 'package/base-files/Makefile')
-rw-r--r--package/base-files/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/package/base-files/Makefile b/package/base-files/Makefile
index 1367fa9291..bf32f6306a 100644
--- a/package/base-files/Makefile
+++ b/package/base-files/Makefile
@@ -11,7 +11,7 @@ include $(INCLUDE_DIR)/kernel.mk
include $(INCLUDE_DIR)/version.mk
PKG_NAME:=base-files
-PKG_RELEASE:=164
+PKG_RELEASE:=165
PKG_FILE_DEPENDS:=$(PLATFORM_DIR)/ $(GENERIC_PLATFORM_DIR)/base-files/
PKG_BUILD_DEPENDS:=usign/host
@@ -161,7 +161,7 @@ define Package/base-files/install
rm -f $(1)/var
$(LN) /tmp $(1)/var
mkdir -p $(1)/etc
- $(LN) /tmp/resolv.conf /tmp/fstab /tmp/TZ $(1)/etc/
+ $(LN) /tmp/resolv.conf /tmp/fstab /tmp/TZ /tmp/localtime $(1)/etc/
chmod 0600 $(1)/etc/shadow
chmod 1777 $(1)/tmp