summaryrefslogtreecommitdiffstats
path: root/package/base-files/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-04-24 12:05:52 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-04-24 12:05:52 +0000
commit383a21f3c591a8ba46ae8336ff5266d7a02fd281 (patch)
treec87e967bb5d3832a3a2ac41b89e01f1536b78644 /package/base-files/Makefile
parent54a1fcd9c16ab3996ec30d2110d45bfca4c6e72d (diff)
downloadmaster-31e0f0ae-383a21f3c591a8ba46ae8336ff5266d7a02fd281.tar.gz
master-31e0f0ae-383a21f3c591a8ba46ae8336ff5266d7a02fd281.tar.bz2
master-31e0f0ae-383a21f3c591a8ba46ae8336ff5266d7a02fd281.zip
use separate sysctl.conf files for 2.4 and 2.6 - fixes some boot message spam
SVN-Revision: 7043
Diffstat (limited to 'package/base-files/Makefile')
-rw-r--r--package/base-files/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/package/base-files/Makefile b/package/base-files/Makefile
index 1e1610c5d7..e267b7f78b 100644
--- a/package/base-files/Makefile
+++ b/package/base-files/Makefile
@@ -13,7 +13,7 @@ PKG_NAME:=base-files
PKG_RELEASE:=8
PKG_BUILD_DIR:=$(KERNEL_BUILD_DIR)/$(PKG_NAME)
-PKG_FILE_DEPEND:=$(PLATFORM_DIR)
+PKG_FILE_DEPEND:=$(PLATFORM_DIR) $(GENERIC_PLATFORM_DIR)/base-files
REV:=$(shell LANG=C svn info | awk '/^Revision:/ { print$$2 }' )
ifeq ($(REV),)
@@ -110,6 +110,9 @@ endef
define Package/base-files$(TARGET)/install
$(CP) ./files/* $(1)/
+ if [ -d $(GENERIC_PLATFORM_DIR)/base-files/. ]; then \
+ $(CP) $(GENERIC_PLATFORM_DIR)/base-files/* $(1)/; \
+ fi
if [ -d $(PLATFORM_DIR)/base-files/default/. ]; then \
$(CP) $(PLATFORM_DIR)/base-files/default/* $(1)/; \
fi