summaryrefslogtreecommitdiffstats
path: root/package/base-files/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2011-03-08 12:48:36 +0000
committerFelix Fietkau <nbd@openwrt.org>2011-03-08 12:48:36 +0000
commit357018e7e53b8374738d16200473382813bbc6af (patch)
tree4ae843d7996991ee1344fb655a9a9e1473de4d33 /package/base-files/Makefile
parent4cd2bef0579739cd4c7f63cf7a92d57597a85d1e (diff)
downloadmaster-31e0f0ae-357018e7e53b8374738d16200473382813bbc6af.tar.gz
master-31e0f0ae-357018e7e53b8374738d16200473382813bbc6af.tar.bz2
master-31e0f0ae-357018e7e53b8374738d16200473382813bbc6af.zip
base-files: the relinked libpthread needs to be linked against libdl, otherwise calls to dlopen() fail (fixes #8978)
SVN-Revision: 25950
Diffstat (limited to 'package/base-files/Makefile')
-rw-r--r--package/base-files/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/base-files/Makefile b/package/base-files/Makefile
index 61296b05ef..07cc8b460a 100644
--- a/package/base-files/Makefile
+++ b/package/base-files/Makefile
@@ -357,7 +357,7 @@ ifeq ($(CONFIG_EXTERNAL_TOOLCHAIN),)
"$(wildcard $(TOOLCHAIN_DIR)/lib/libpthread_so.a)" \
"$(patsubst $(TOOLCHAIN_DIR)/lib/%,$(PKG_BUILD_DIR)/%,$(wildcard $(TOOLCHAIN_DIR)/lib/libpthread-*.so))" \
-Wl,-z,nodelete,-z,initfirst,-init=__pthread_initialize_minimal_internal \
- $(BUILD_LIBGCC) \
+ -ldl $(BUILD_LIBGCC) \
-Wl,-soname=libpthread.so.0
endef
ifneq ($(BUILD_LIBGCC),)