summaryrefslogtreecommitdiffstats
path: root/package/b43/src/Makefile
diff options
context:
space:
mode:
authorMichael Büsch <mb@bu3sch.de>2008-02-15 22:47:47 +0000
committerMichael Büsch <mb@bu3sch.de>2008-02-15 22:47:47 +0000
commit99aaf500ed5ca39f30cebf79dc0ee9ff1fd8becf (patch)
tree382f2e40c89aea52fbc7223c66466e1cd4138def /package/b43/src/Makefile
parent4e45a1d1acaaf25be8bd435031634ad23a5a205d (diff)
downloadmaster-31e0f0ae-99aaf500ed5ca39f30cebf79dc0ee9ff1fd8becf.tar.gz
master-31e0f0ae-99aaf500ed5ca39f30cebf79dc0ee9ff1fd8becf.tar.bz2
master-31e0f0ae-99aaf500ed5ca39f30cebf79dc0ee9ff1fd8becf.zip
Upgrade b43 and mac80211.
This also temporarly disables hostapd support for mac80211, as hostapd needs patches to compile against latest mac80211. Will do that in a seperate patch. SVN-Revision: 10466
Diffstat (limited to 'package/b43/src/Makefile')
-rw-r--r--package/b43/src/Makefile12
1 files changed, 4 insertions, 8 deletions
diff --git a/package/b43/src/Makefile b/package/b43/src/Makefile
index 485e59e2df..ac1329dba0 100644
--- a/package/b43/src/Makefile
+++ b/package/b43/src/Makefile
@@ -1,20 +1,16 @@
-# b43 core
b43-y += main.o
b43-y += tables.o
+b43-y += tables_nphy.o
b43-y += phy.o
+b43-y += nphy.o
b43-y += sysfs.o
b43-y += xmit.o
b43-y += lo.o
-# b43 RFKILL button support
+b43-y += wa.o
+b43-y += dma.o
b43-$(CONFIG_B43_RFKILL) += rfkill.o
-# b43 LED support
b43-$(CONFIG_B43_LEDS) += leds.o
-# b43 PCMCIA support
b43-$(CONFIG_B43_PCMCIA) += pcmcia.o
-# b43 debugging
b43-$(CONFIG_B43_DEBUG) += debugfs.o
-# b43 DMA and PIO
-b43-$(CONFIG_B43_DMA) += dma.o
-b43-$(CONFIG_B43_PIO) += pio.o
obj-$(CONFIG_B43) += b43.o