summaryrefslogtreecommitdiffstats
path: root/package/ar7-atm/patches
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2006-10-24 13:42:03 +0000
committerFelix Fietkau <nbd@openwrt.org>2006-10-24 13:42:03 +0000
commitea03a8d6819ccbf0dc7582d73c8f75c115b3b991 (patch)
treec6e94b70ab4b9bf70d31b634156b9618db7fbfcf /package/ar7-atm/patches
parente5b4b6a757c66850b17495fc7a2496e02d190589 (diff)
downloadmaster-31e0f0ae-ea03a8d6819ccbf0dc7582d73c8f75c115b3b991.tar.gz
master-31e0f0ae-ea03a8d6819ccbf0dc7582d73c8f75c115b3b991.tar.bz2
master-31e0f0ae-ea03a8d6819ccbf0dc7582d73c8f75c115b3b991.zip
fix tiatm compile
SVN-Revision: 5275
Diffstat (limited to 'package/ar7-atm/patches')
-rw-r--r--package/ar7-atm/patches/100-compile_fix.patch28
1 files changed, 28 insertions, 0 deletions
diff --git a/package/ar7-atm/patches/100-compile_fix.patch b/package/ar7-atm/patches/100-compile_fix.patch
new file mode 100644
index 0000000000..46b0b0c485
--- /dev/null
+++ b/package/ar7-atm/patches/100-compile_fix.patch
@@ -0,0 +1,28 @@
+diff -ur sangam.old/Makefile sangam.dev/Makefile
+--- sangam.old/Makefile 2006-10-17 16:43:09.000000000 +0200
++++ sangam.dev/Makefile 2006-10-24 15:34:14.000000000 +0200
+@@ -1,17 +1,15 @@
+-# File: drivers/net/avalanche_cpmac/Makefile
+ #
+-# Makefile for the Linux network (CPMAC) device drivers.
++# Makefile for the TIATM device drivers.
+ #
+
+-
+ O_TARGET := tiatm.o
++obj-m := tiatm.o
++
++tiatm-objs += tn7atm.o tn7dsl.o tn7sar.o dsl_hal_api.o dsl_hal_support.o cpsar.o aal5sar.o
++EXTRA_CFLAGS += -DEL -I. -DPOST_SILICON -DCOMMON_NSP -DCONFIG_LED_MODULE -DDEREGISTER_LED -DNO_ACT
+
+-obj-m += tiatm.o
+-tiatm-objs := tn7atm.o tn7dsl.o tn7sar.o dsl_hal_api.o dsl_hal_support.o cpsar.o aal5sar.o
++include $(TOPDIR)/Rules.make
+
+ tiatm.o: $(tiatm-objs)
+- $(LD) $(LDOPTS) -o wlan.$(KMODSUF) -r $(tiatm-objs)
+-
+-EXTRA_CFLAGS += -DEL -I. -DPOST_SILICON -DCOMMON_NSP -DCONFIG_LED_MODULE -DDEREGISTER_LED -DNO_ACT
++ $(LD) -r $(LDOPTS) -o $@ $(tiatm-objs)
+
+--include $(TOPDIR)/Rules.make