summaryrefslogtreecommitdiffstats
path: root/package/acx-mac80211
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-11-07 23:16:37 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-11-07 23:16:37 +0000
commit64e1a619c22e12d3fe9d30699a2baf4842501892 (patch)
tree9876e973d13e6a07d66ee57a01388789795966d3 /package/acx-mac80211
parent2687c81ab04416219827f21caeeb225ecf925bc3 (diff)
downloadmaster-31e0f0ae-64e1a619c22e12d3fe9d30699a2baf4842501892.tar.gz
master-31e0f0ae-64e1a619c22e12d3fe9d30699a2baf4842501892.tar.bz2
master-31e0f0ae-64e1a619c22e12d3fe9d30699a2baf4842501892.zip
fix acx-mac80211 compile with older kernels
SVN-Revision: 9512
Diffstat (limited to 'package/acx-mac80211')
-rw-r--r--package/acx-mac80211/Makefile10
1 files changed, 5 insertions, 5 deletions
diff --git a/package/acx-mac80211/Makefile b/package/acx-mac80211/Makefile
index effa403a25..a3c16ec093 100644
--- a/package/acx-mac80211/Makefile
+++ b/package/acx-mac80211/Makefile
@@ -42,6 +42,7 @@ $(STAMP_BUILT): $(DL_DIR)/$(PKG_FW_NAME)
$(DL_DIR)/$(PKG_FW_NAME):
$(SCRIPT_DIR)/download.pl "$(DL_DIR)" "$(PKG_FW_NAME)" "$(PKG_FW_MD5SUM)" $(PKG_FW_URL)
+ifneq ($(findstring 2.6.23,$(LINUX_VERSION)),)
PKG_EXTRA_KCONFIG:= \
CONFIG_ACX_MAC80211=m \
CONFIG_ACX_MAC80211_PCI=m \
@@ -50,7 +51,7 @@ $(DL_DIR)/$(PKG_FW_NAME):
$(patsubst CONFIG_%, -DCONFIG_%=1, $(patsubst %=m,%,$(filter %=m,$(PKG_EXTRA_KCONFIG)))) \
$(patsubst CONFIG_%, -DCONFIG_%=1, $(patsubst %=y,%,$(filter %=y,$(PKG_EXTRA_KCONFIG)))) \
- define Build/Compile/it
+ define Build/Compile
$(MAKE) -C "$(LINUX_DIR)" \
ARCH="$(LINUX_KARCH)" \
CROSS_COMPILE="$(TARGET_CROSS)" \
@@ -62,14 +63,13 @@ $(DL_DIR)/$(PKG_FW_NAME):
V="$(V)" \
modules
endef
+else
+ override CONFIG_PACKAGE_kmod-acx-mac80211=
+endif
define Build/Configure
endef
-define Build/Compile
-$(call Build/Compile/it)
-endef
-
define KernelPackage/acx-mac80211/install
$(INSTALL_DIR) $(1)/lib/firmware
$(INSTALL_DATA) $(DL_DIR)/$(PKG_FW_NAME) $(1)/lib/firmware/