summaryrefslogtreecommitdiffstats
path: root/package/Makefile
diff options
context:
space:
mode:
authorMike Baker <mbm@openwrt.org>2007-04-11 22:59:42 +0000
committerMike Baker <mbm@openwrt.org>2007-04-11 22:59:42 +0000
commit9b62c7eb9d767956f9bc4066341b24077dce4332 (patch)
tree8ade56dd2246807dd06e523a6cfa9d6dfe24c2ff /package/Makefile
parent30dfff4849d178906314dabe3180e96b29ad423d (diff)
downloadmaster-31e0f0ae-9b62c7eb9d767956f9bc4066341b24077dce4332.tar.gz
master-31e0f0ae-9b62c7eb9d767956f9bc4066341b24077dce4332.tar.bz2
master-31e0f0ae-9b62c7eb9d767956f9bc4066341b24077dce4332.zip
minor tweaks to the verbose system
SVN-Revision: 6936
Diffstat (limited to 'package/Makefile')
-rw-r--r--package/Makefile13
1 files changed, 9 insertions, 4 deletions
diff --git a/package/Makefile b/package/Makefile
index 9b8f872924..17233bbbfa 100644
--- a/package/Makefile
+++ b/package/Makefile
@@ -16,18 +16,23 @@ include $(TMP_DIR)/.packagedeps
PREREQ_PACKAGES:=$(patsubst %,%-prereq,$(prereq-y) $(prereq-m))
DOWNLOAD_PACKAGES:=$(patsubst %,%-download,$(package-y) $(package-m))
-COMPILE_PACKAGES:=$(patsubst %,%-compile,$(package-y) $(package-m))
+COMPILE_PACKAGES:=$(patsubst %,%-compile,$(package-m))
INSTALL_PACKAGES:=$(patsubst %,%-install,$(package-y))
$(STAMP_DIR) $(TARGET_DIR):
mkdir -p $@
+ifeq ($(QUIET),1)
+%-compile %-install: FORCE
+ $(MAKE) -C $* $(patsubst $*-%,%,$@) || { $(call MESSAGE, "*** $* $(patsubst $*-%,%,$@) failed"); false; }
+
+%-prereq %-download %-clean: FORCE
+else
%-prereq %-download %-clean %-compile %-install: FORCE
+endif
$(MAKE) -C $* $(patsubst $*-%,%,$@)
-%-prereq: $(STAMP_DIR) $(TARGET_DIR)
-%-prepare: $(TARGET_DIR)
-%-compile: %-prepare
+# .IGNORE: $(COMPILE_PACKAGES)
$(TMP_DIR)/.packagedeps: $(TMP_DIR)/.packageinfo
@$(TOPDIR)/scripts/metadata.pl package_mk < $< > $@ || rm -f $@