summaryrefslogtreecommitdiffstats
path: root/package/Makefile
diff options
context:
space:
mode:
authorMike Baker <mbm@openwrt.org>2007-04-03 23:03:56 +0000
committerMike Baker <mbm@openwrt.org>2007-04-03 23:03:56 +0000
commit23efe5fc834671d6d2842630ec28ed829a298fe9 (patch)
treedc0a4deb91f74428e18271e1f4b2082f08e1380f /package/Makefile
parentda8174507aad3763465d31a3de34f6765057bc18 (diff)
downloadmaster-31e0f0ae-23efe5fc834671d6d2842630ec28ed829a298fe9.tar.gz
master-31e0f0ae-23efe5fc834671d6d2842630ec28ed829a298fe9.tar.bz2
master-31e0f0ae-23efe5fc834671d6d2842630ec28ed829a298fe9.zip
Tidy up Makefiles
SVN-Revision: 6857
Diffstat (limited to 'package/Makefile')
-rw-r--r--package/Makefile23
1 files changed, 6 insertions, 17 deletions
diff --git a/package/Makefile b/package/Makefile
index 06e91042bc..9b8f872924 100644
--- a/package/Makefile
+++ b/package/Makefile
@@ -12,7 +12,7 @@ include $(INCLUDE_DIR)/host.mk
all: compile
-include $(TMP_DIR)/.pkgdeps
+include $(TMP_DIR)/.packagedeps
PREREQ_PACKAGES:=$(patsubst %,%-prereq,$(prereq-y) $(prereq-m))
DOWNLOAD_PACKAGES:=$(patsubst %,%-download,$(package-y) $(package-m))
@@ -22,25 +22,14 @@ INSTALL_PACKAGES:=$(patsubst %,%-install,$(package-y))
$(STAMP_DIR) $(TARGET_DIR):
mkdir -p $@
-%-prereq: $(STAMP_DIR) $(TARGET_DIR)
- $(MAKE) -C $(patsubst %-prereq,%,$@) prereq
-
-%-download: FORCE
- $(MAKE) -C $(patsubst %-download,%,$@) download
-
-%-prepare: $(TARGET_DIR) FORCE
- $(MAKE) -C $(patsubst %-prepare,%,$@) prepare
+%-prereq %-download %-clean %-compile %-install: FORCE
+ $(MAKE) -C $* $(patsubst $*-%,%,$@)
+%-prereq: $(STAMP_DIR) $(TARGET_DIR)
+%-prepare: $(TARGET_DIR)
%-compile: %-prepare
- $(MAKE) -C $(patsubst %-compile,%,$@) compile
-
-%-install:
- $(MAKE) -C $(patsubst %-install,%,$@) install
-
-%-clean: FORCE
- $(MAKE) -C $(patsubst %-clean,%,$@) clean
-$(TMP_DIR)/.pkgdeps: $(TMP_DIR)/.pkginfo
+$(TMP_DIR)/.packagedeps: $(TMP_DIR)/.packageinfo
@$(TOPDIR)/scripts/metadata.pl package_mk < $< > $@ || rm -f $@
preconfig: