summaryrefslogtreecommitdiffstats
path: root/package/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2006-12-01 14:01:31 +0000
committerFelix Fietkau <nbd@openwrt.org>2006-12-01 14:01:31 +0000
commit0a4052dd78b729795b10a879b8b18d736900f1f9 (patch)
tree0319aa35bfb827f5de29af5c3392d2c87194d74d /package/Makefile
parent5af24a0373b96ac1798798e69699ea6b1f59a2b9 (diff)
downloadmaster-31e0f0ae-0a4052dd78b729795b10a879b8b18d736900f1f9.tar.gz
master-31e0f0ae-0a4052dd78b729795b10a879b8b18d736900f1f9.tar.bz2
master-31e0f0ae-0a4052dd78b729795b10a879b8b18d736900f1f9.zip
allow people to add files to the rootfs by putting them in $(TOPDIR)/files/
SVN-Revision: 5685
Diffstat (limited to 'package/Makefile')
-rw-r--r--package/Makefile3
1 files changed, 3 insertions, 0 deletions
diff --git a/package/Makefile b/package/Makefile
index e0483deb59..34eba4e3b1 100644
--- a/package/Makefile
+++ b/package/Makefile
@@ -55,6 +55,9 @@ install-targets: base-files-install $(INSTALL_PACKAGES)
install:
rm -rf $(BUILD_DIR)/root
$(MAKE) install-targets
+ @if [ -d $(TOPDIR)/files ]; then \
+ $(CP) $(TOPDIR)/files/. $(BUILD_DIR)/root; \
+ fi
@( \
cd $(BUILD_DIR)/root; \
for script in ./etc/init.d/*; do \