summaryrefslogtreecommitdiffstats
path: root/package/6in4
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2010-07-09 00:17:31 +0000
committerJo-Philipp Wich <jow@openwrt.org>2010-07-09 00:17:31 +0000
commit9b5e8c5913c9ccb3d3cb88d1527786032a1dac06 (patch)
tree23633d4d2296a23659f99286e6e9fb2c284133db /package/6in4
parent1d45111aa57e1007321d15ac9ffe949e1a4341d7 (diff)
downloadmaster-31e0f0ae-9b5e8c5913c9ccb3d3cb88d1527786032a1dac06.tar.gz
master-31e0f0ae-9b5e8c5913c9ccb3d3cb88d1527786032a1dac06.tar.bz2
master-31e0f0ae-9b5e8c5913c9ccb3d3cb88d1527786032a1dac06.zip
6in4: automatically determine wan interface in hotplug events
SVN-Revision: 22102
Diffstat (limited to 'package/6in4')
-rw-r--r--package/6in4/Makefile2
-rw-r--r--package/6in4/files/6in4.hotplug2
2 files changed, 2 insertions, 2 deletions
diff --git a/package/6in4/Makefile b/package/6in4/Makefile
index d88ee16066..75e7848825 100644
--- a/package/6in4/Makefile
+++ b/package/6in4/Makefile
@@ -8,7 +8,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=6in4
-PKG_VERSION:=2
+PKG_VERSION:=3
PKG_RELEASE:=1
include $(INCLUDE_DIR)/package.mk
diff --git a/package/6in4/files/6in4.hotplug b/package/6in4/files/6in4.hotplug
index 0a196c25b0..96b046d14d 100644
--- a/package/6in4/files/6in4.hotplug
+++ b/package/6in4/files/6in4.hotplug
@@ -14,7 +14,7 @@ if [ "$ACTION" = ifup ]; then
[ "$proto" = 6in4 ] || return 0
local wandev
- config_get wandev "$cfg" wan_device
+ config_get wandev "$cfg" wan_device "$(find_6in4_wanif)"
[ "$wandev" = "$DEVICE" ] || return 0
local oldip