summaryrefslogtreecommitdiffstats
path: root/package/6in4
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2010-09-04 16:09:49 +0000
committerJo-Philipp Wich <jow@openwrt.org>2010-09-04 16:09:49 +0000
commit52dcaeb65d0959543104fd470e167f18a8a97fc9 (patch)
tree42088c7ac65bb9af772e13a9522d7068060f55b6 /package/6in4
parent6edf2c577b22c3030acdeda3f9987846374f0193 (diff)
downloadmaster-31e0f0ae-52dcaeb65d0959543104fd470e167f18a8a97fc9.tar.gz
master-31e0f0ae-52dcaeb65d0959543104fd470e167f18a8a97fc9.tar.bz2
master-31e0f0ae-52dcaeb65d0959543104fd470e167f18a8a97fc9.zip
6in4: replace sed match with variable substitution, change pattern from a-z to a-f (hex only)
SVN-Revision: 22893
Diffstat (limited to 'package/6in4')
-rw-r--r--package/6in4/Makefile2
-rw-r--r--package/6in4/files/6in4.hotplug2
2 files changed, 2 insertions, 2 deletions
diff --git a/package/6in4/Makefile b/package/6in4/Makefile
index c56b9c57ce..b9fa220df7 100644
--- a/package/6in4/Makefile
+++ b/package/6in4/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=6in4
PKG_VERSION:=5
-PKG_RELEASE:=1
+PKG_RELEASE:=2
include $(INCLUDE_DIR)/package.mk
diff --git a/package/6in4/files/6in4.hotplug b/package/6in4/files/6in4.hotplug
index b695b527ed..790edc0e15 100644
--- a/package/6in4/files/6in4.hotplug
+++ b/package/6in4/files/6in4.hotplug
@@ -32,7 +32,7 @@ if [ "$ACTION" = ifup ]; then
config_get password "$cfg" password
[ -n "$tunnelid" ] && [ -n "$username" ] && [ -n "$password" ] && {
- [ "${#password}" != 32 ] || [ -n "$(echo "$password" | sed 's/[a-z0-9]//g')" ] && {
+ [ "${#password}" == 32 -a -z "${password//[a-f0-9]/}" ] && {
password="$(echo -n "$password" | md5sum)"; password="${password%% *}"
}
uci_set_state network "$cfg" ipaddr "$wanip"