summaryrefslogtreecommitdiffstats
path: root/package/6in4/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2012-03-19 21:10:04 +0000
committerFelix Fietkau <nbd@openwrt.org>2012-03-19 21:10:04 +0000
commit3454c35127118f26479c4b5972800c63b4e8515f (patch)
tree9ce892cf6bf169b7f7e6bbd2e7696d8dc3d8f33e /package/6in4/Makefile
parent1147799b854c737693e8e07a8aed960273d2e2b0 (diff)
downloadmaster-31e0f0ae-3454c35127118f26479c4b5972800c63b4e8515f.tar.gz
master-31e0f0ae-3454c35127118f26479c4b5972800c63b4e8515f.tar.bz2
master-31e0f0ae-3454c35127118f26479c4b5972800c63b4e8515f.zip
6in4: add netifd support
SVN-Revision: 31036
Diffstat (limited to 'package/6in4/Makefile')
-rw-r--r--package/6in4/Makefile17
1 files changed, 13 insertions, 4 deletions
diff --git a/package/6in4/Makefile b/package/6in4/Makefile
index fb0803a8a6..ee53f5e3ca 100644
--- a/package/6in4/Makefile
+++ b/package/6in4/Makefile
@@ -34,11 +34,20 @@ endef
define Build/Configure
endef
-define Package/6in4/install
- $(INSTALL_DIR) $(1)/lib/network
- $(INSTALL_DATA) ./files/6in4.sh $(1)/lib/network/6in4.sh
+ifneq ($(CONFIG_PACKAGE_netifd),)
+ define Package/6in4/install
+ $(INSTALL_DIR) $(1)/lib/netifd/proto
+ $(INSTALL_BIN) ./files/6in4.sh $(1)/lib/netifd/proto/6in4.sh
$(INSTALL_DIR) $(1)/etc/hotplug.d/iface
$(INSTALL_DATA) ./files/6in4.hotplug $(1)/etc/hotplug.d/iface/90-6in4
-endef
+ endef
+else
+ define Package/6in4/install
+ $(INSTALL_DIR) $(1)/lib/network
+ $(INSTALL_DATA) ./files.old/6in4.sh $(1)/lib/network/6in4.sh
+ $(INSTALL_DIR) $(1)/etc/hotplug.d/iface
+ $(INSTALL_DATA) ./files.old/6in4.hotplug $(1)/etc/hotplug.d/iface/90-6in4
+ endef
+endif
$(eval $(call BuildPackage,6in4))