summaryrefslogtreecommitdiffstats
path: root/package/6in4/Makefile
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2010-05-28 22:03:30 +0000
committerJo-Philipp Wich <jow@openwrt.org>2010-05-28 22:03:30 +0000
commit0bd7c654472835f967d1741d64ab853a987ea758 (patch)
treefd0167d4f9fb8d584148a55cf2921753f5f24510 /package/6in4/Makefile
parent8dd583e3a40ae2e19677e33b3aad9695ac33e8b9 (diff)
downloadmaster-31e0f0ae-0bd7c654472835f967d1741d64ab853a987ea758.tar.gz
master-31e0f0ae-0bd7c654472835f967d1741d64ab853a987ea758.tar.bz2
master-31e0f0ae-0bd7c654472835f967d1741d64ab853a987ea758.zip
6in4: - support to automatically determine the local endpoint address from the current IPv4 default gateway - support updating the tunnel endpoint for he.net
SVN-Revision: 21612
Diffstat (limited to 'package/6in4/Makefile')
-rw-r--r--package/6in4/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/package/6in4/Makefile b/package/6in4/Makefile
index 725c283ded..d88ee16066 100644
--- a/package/6in4/Makefile
+++ b/package/6in4/Makefile
@@ -8,7 +8,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=6in4
-PKG_VERSION:=1
+PKG_VERSION:=2
PKG_RELEASE:=1
include $(INCLUDE_DIR)/package.mk
@@ -36,6 +36,8 @@ endef
define Package/6in4/install
$(INSTALL_DIR) $(1)/lib/network
$(INSTALL_DATA) ./files/6in4.sh $(1)/lib/network/6in4.sh
+ $(INSTALL_DIR) $(1)/etc/hotplug.d/iface
+ $(INSTALL_DATA) ./files/6in4.hotplug $(1)/etc/hotplug.d/iface/90-6in4
endef
$(eval $(call BuildPackage,6in4))