summaryrefslogtreecommitdiffstats
path: root/include
diff options
context:
space:
mode:
authorMathias Kresin <dev@kresin.me>2016-09-03 07:40:15 +0200
committerMathias Kresin <dev@kresin.me>2016-09-03 07:40:15 +0200
commitddd259b0d5d0d4ec0084cb7cb30992b63780e962 (patch)
tree9aa39d2b07fa26ec481dc3684ecabc5e6b89e228 /include
parent85fefcdb61e9362abbb16eb2a9d3e6dda19a175b (diff)
downloadmaster-31e0f0ae-ddd259b0d5d0d4ec0084cb7cb30992b63780e962.tar.gz
master-31e0f0ae-ddd259b0d5d0d4ec0084cb7cb30992b63780e962.tar.bz2
master-31e0f0ae-ddd259b0d5d0d4ec0084cb7cb30992b63780e962.zip
image: pass device blocksize to padjffs2
At the moment the padding steps are hardcoded. Especially images for devices with a 4K sector size can be unnecessarily bloated using the hardcoded padding steps. It has been observed that 192Kb of padding was added to the image of a 4MB device, albeit due to the 4K sector size the minimum required extra padding for the jffs2 rootfs_data is 20Kb. In worst case it means that the image-size check could fail albeit there is enough space for all selected packages For device build code not exposing the blocksize, use the hardcoded padding further on. Signed-off-by: Mathias Kresin <dev@kresin.me>
Diffstat (limited to 'include')
-rw-r--r--include/image-commands.mk3
1 files changed, 2 insertions, 1 deletions
diff --git a/include/image-commands.mk b/include/image-commands.mk
index 6cb5bff4ab..9db150c905 100644
--- a/include/image-commands.mk
+++ b/include/image-commands.mk
@@ -131,7 +131,8 @@ define Build/pad-to
endef
define Build/pad-rootfs
- $(STAGING_DIR_HOST)/bin/padjffs2 $@ $(1) 4 8 16 64 128 256
+ $(STAGING_DIR_HOST)/bin/padjffs2 $@ $(1) \
+ $(if $(BLOCKSIZE),$(BLOCKSIZE:%k=%),4 8 16 64 128 256)
endef
define Build/pad-offset