summaryrefslogtreecommitdiffstats
path: root/include
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2016-07-22 14:04:16 +0200
committerFelix Fietkau <nbd@nbd.name>2016-07-29 10:18:26 +0200
commitc0dceae4bbb3aab0c4fcaf229925e8916d286797 (patch)
tree107b7c1b063f01db17735494c1a3e8dff8b08e85 /include
parent653cb2594d34439f292cf973747ee84bb266ca9e (diff)
downloadmaster-31e0f0ae-c0dceae4bbb3aab0c4fcaf229925e8916d286797.tar.gz
master-31e0f0ae-c0dceae4bbb3aab0c4fcaf229925e8916d286797.tar.bz2
master-31e0f0ae-c0dceae4bbb3aab0c4fcaf229925e8916d286797.zip
build: minor cleanup of redundant code
Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'include')
-rw-r--r--include/image-legacy.mk2
-rw-r--r--include/image.mk6
2 files changed, 6 insertions, 2 deletions
diff --git a/include/image-legacy.mk b/include/image-legacy.mk
index da8279c263..9ace98fbe5 100644
--- a/include/image-legacy.mk
+++ b/include/image-legacy.mk
@@ -36,7 +36,7 @@ endif
LegacyDevice/Dump = $(Device/Dump)
define LegacyDevice/Check
- _PROFILE_SET = $$(strip $$(foreach profile,$$(PROFILES) DEVICE_$(1),$$(call DEVICE_CHECK_PROFILE,$$(profile))))
+ $(Device/Check/Common)
_TARGET_PREPARE := $$(if $$(_PROFILE_SET),legacy-images-prepare,prepare-disabled)
_TARGET := $$(if $$(_PROFILE_SET),legacy-images,install-disabled)
$$(if $$(_PROFILE_SET),install: legacy-images-make)
diff --git a/include/image.mk b/include/image.mk
index 8cc6a91373..5970e58e1a 100644
--- a/include/image.mk
+++ b/include/image.mk
@@ -345,9 +345,13 @@ else
DEVICE_CHECK_PROFILE = $(CONFIG_TARGET_$(if $(CONFIG_TARGET_MULTI_PROFILE),DEVICE_)$(call target_conf,$(BOARD)$(if $(SUBTARGET),_$(SUBTARGET)))_$(1))
endif
+define Device/Check/Common
+ _PROFILE_SET = $$(strip $$(foreach profile,$$(PROFILES) DEVICE_$(1),$$(call DEVICE_CHECK_PROFILE,$$(profile))))
+endef
+
define Device/Check
+ $(Device/Check/Common)
KDIR_KERNEL_IMAGE := $(KDIR)/$(1)$$(KERNEL_SUFFIX)
- _PROFILE_SET = $$(strip $$(foreach profile,$$(PROFILES) DEVICE_$(1),$$(call DEVICE_CHECK_PROFILE,$$(profile))))
_TARGET := $$(if $$(_PROFILE_SET),install-images,install-disabled)
ifndef IB
_COMPILE_TARGET := $$(if $(CONFIG_IB)$$(_PROFILE_SET),compile,compile-disabled)