summaryrefslogtreecommitdiffstats
path: root/include
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2016-07-13 17:23:00 +0200
committerFelix Fietkau <nbd@nbd.name>2016-07-14 10:27:30 +0200
commitb8fddb8912dfe1d2405b685680f7bb1a0b10937a (patch)
tree91a0918d45b04ab078fedde7a85b7510bfed14a0 /include
parente0ed6ec667c74ae48694808626d3bf00bea12b2b (diff)
downloadmaster-31e0f0ae-b8fddb8912dfe1d2405b685680f7bb1a0b10937a.tar.gz
master-31e0f0ae-b8fddb8912dfe1d2405b685680f7bb1a0b10937a.tar.bz2
master-31e0f0ae-b8fddb8912dfe1d2405b685680f7bb1a0b10937a.zip
image: allow devices to override the -E 5 ubinize option
Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'include')
-rw-r--r--include/image-commands.mk5
-rw-r--r--include/image.mk4
2 files changed, 6 insertions, 3 deletions
diff --git a/include/image-commands.mk b/include/image-commands.mk
index e8549d46f6..17ab46d859 100644
--- a/include/image-commands.mk
+++ b/include/image-commands.mk
@@ -105,8 +105,9 @@ define Build/append-ubi
$(if $(KERNEL_IN_UBI),--kernel $(word 1,$^)) \
$(word 2,$^) \
$@.tmp \
- -p $(BLOCKSIZE) -m $(PAGESIZE) -E 5 \
- $(if $(SUBPAGESIZE),-s $(SUBPAGESIZE))
+ -p $(BLOCKSIZE) -m $(PAGESIZE) \
+ $(if $(SUBPAGESIZE),-s $(SUBPAGESIZE)) \
+ $(UBINIZE_OPTS)
cat $@.tmp >> $@
rm $@.tmp
endef
diff --git a/include/image.mk b/include/image.mk
index a1e00df716..bf5f0a6a20 100644
--- a/include/image.mk
+++ b/include/image.mk
@@ -327,6 +327,7 @@ define Device/Init
BLOCKSIZE :=
PAGESIZE :=
SUBPAGESIZE :=
+ UBINIZE_OPTS := -E 5
FILESYSTEMS := $(TARGET_FILESYSTEMS)
endef
@@ -334,7 +335,8 @@ endef
DEFAULT_DEVICE_VARS := \
DEVICE_NAME KERNEL KERNEL_INITRAMFS KERNEL_INITRAMFS_IMAGE \
UBOOTENV_IN_UBI KERNEL_IN_UBI \
- BLOCKSIZE PAGESIZE SUBPAGESIZE
+ BLOCKSIZE PAGESIZE SUBPAGESIZE \
+ UBINIZE_OPTS
define Device/ExportVar
$(1) : $(2):=$$($(2))