summaryrefslogtreecommitdiffstats
path: root/include
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-04-29 01:30:48 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-04-29 01:30:48 +0000
commit874f03ea007ec022c344bd2814aded1545650b5c (patch)
tree48c21175fe5bce7afddda4172e5ae0d2e3b25859 /include
parent0212ef08bd1af96a0e34782d3a7affa7d03fbe4d (diff)
downloadmaster-31e0f0ae-874f03ea007ec022c344bd2814aded1545650b5c.tar.gz
master-31e0f0ae-874f03ea007ec022c344bd2814aded1545650b5c.tar.bz2
master-31e0f0ae-874f03ea007ec022c344bd2814aded1545650b5c.zip
fixes for a few build errors on osx without fink
SVN-Revision: 7065
Diffstat (limited to 'include')
-rw-r--r--include/host.mk6
-rw-r--r--include/image.mk7
-rw-r--r--include/package-ipkg.mk6
3 files changed, 13 insertions, 6 deletions
diff --git a/include/host.mk b/include/host.mk
index 423ca16610..8b4ce3d24b 100644
--- a/include/host.mk
+++ b/include/host.mk
@@ -35,3 +35,9 @@ $(TMP_DIR)/.host.mk: $(TOPDIR)/include/host.mk
)
endif
+
+ifeq ($(HOST_OS),Linux)
+ XARGS:=xargs -r
+else
+ XARGS:=xargs
+endif
diff --git a/include/image.mk b/include/image.mk
index 0e6a7cdbea..f814f61d77 100644
--- a/include/image.mk
+++ b/include/image.mk
@@ -7,6 +7,7 @@
include $(INCLUDE_DIR)/prereq.mk
include $(INCLUDE_DIR)/kernel.mk
+include $(INCLUDE_DIR)/host.mk
KDIR:=$(BUILD_DIR)/linux-$(KERNEL)-$(BOARD)
ifneq ($(CONFIG_BIG_ENDIAN),y)
@@ -79,9 +80,9 @@ endif
define Image/mkfs/prepare/default
- find $(BUILD_DIR)/root -type f -not -perm +0100 -not -name 'ssh_host*' | xargs -r chmod 0644
- find $(BUILD_DIR)/root -type f -perm +0100 | xargs -r chmod 0755
- find $(BUILD_DIR)/root -type d | xargs -r chmod 0755
+ find $(BUILD_DIR)/root -type f -not -perm +0100 -not -name 'ssh_host*' | $(XARGS) chmod 0644
+ find $(BUILD_DIR)/root -type f -perm +0100 | $(XARGS) chmod 0755
+ find $(BUILD_DIR)/root -type d | $(XARGS) chmod 0755
mkdir -p $(BUILD_DIR)/root/tmp
chmod 0777 $(BUILD_DIR)/root/tmp
endef
diff --git a/include/package-ipkg.mk b/include/package-ipkg.mk
index ac6912844b..20d1326133 100644
--- a/include/package-ipkg.mk
+++ b/include/package-ipkg.mk
@@ -63,9 +63,9 @@ ifeq ($(DUMP),)
$$(IPKG_$(1)): $(PKG_BUILD_DIR)/.built $$(IDIR_$(1))/CONTROL/control
$(call Package/$(1)/install,$$(IDIR_$(1)))
mkdir -p $(PACKAGE_DIR)
- -find $$(IDIR_$(1)) -name CVS | xargs -r rm -rf
- -find $$(IDIR_$(1)) -name .svn | xargs -r rm -rf
- -find $$(IDIR_$(1)) -name '.#*' | xargs -r rm -f
+ -find $$(IDIR_$(1)) -name CVS | $(XARGS) rm -rf
+ -find $$(IDIR_$(1)) -name .svn | $(XARGS) rm -rf
+ -find $$(IDIR_$(1)) -name '.#*' | $(XARGS) rm -f
$(RSTRIP) $$(IDIR_$(1))
$(IPKG_BUILD) $$(IDIR_$(1)) $(PACKAGE_DIR)
@[ -f $$(IPKG_$(1)) ] || false