summaryrefslogtreecommitdiffstats
path: root/include
diff options
context:
space:
mode:
authorMathias Kresin <dev@kresin.me>2016-09-11 19:05:20 +0200
committerMathias Kresin <dev@kresin.me>2016-09-13 19:36:41 +0200
commit61c2a7339a70b34cc357f9f190921365c39073f9 (patch)
tree147d330471abdc1c7908ab37608ca547bcca93f1 /include
parent14b40d61e13ce0408d5ed9dff2ad3a18ab0c2471 (diff)
downloadmaster-31e0f0ae-61c2a7339a70b34cc357f9f190921365c39073f9.tar.gz
master-31e0f0ae-61c2a7339a70b34cc357f9f190921365c39073f9.tar.bz2
master-31e0f0ae-61c2a7339a70b34cc357f9f190921365c39073f9.zip
image: remove padding parameter from append-kernel/append-rootfs
Using pad-to instead of passing the optional padding to append-kernel or append-rootfs. It could be that the value of a variable is passed. In case the variable is empty no error is thrown. Furthermore the purpose of the extra parameter is hard to get without reading the code. Signed-off-by: Mathias Kresin <dev@kresin.me>
Diffstat (limited to 'include')
-rw-r--r--include/image-commands.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/include/image-commands.mk b/include/image-commands.mk
index 7ff4c217a3..6386e55b79 100644
--- a/include/image-commands.mk
+++ b/include/image-commands.mk
@@ -103,11 +103,11 @@ define Build/patch-cmdline
endef
define Build/append-kernel
- dd if=$(IMAGE_KERNEL) $(if $(1),bs=$(1) conv=sync) >> $@
+ dd if=$(IMAGE_KERNEL) >> $@
endef
define Build/append-rootfs
- dd if=$(IMAGE_ROOTFS) $(if $(1),bs=$(1) conv=sync) >> $@
+ dd if=$(IMAGE_ROOTFS) >> $@
endef
define Build/append-ubi