summaryrefslogtreecommitdiffstats
path: root/include
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2014-10-05 16:41:33 +0000
committerFelix Fietkau <nbd@openwrt.org>2014-10-05 16:41:33 +0000
commit5e4789671ae4ecd9d2eb239e865f15ef60232287 (patch)
tree8c32bb5c5e48e4a14c1b8bc97506ca1afaa03466 /include
parent646dfde8264fc9646c30e04ca6453b519a7e6651 (diff)
downloadmaster-31e0f0ae-5e4789671ae4ecd9d2eb239e865f15ef60232287.tar.gz
master-31e0f0ae-5e4789671ae4ecd9d2eb239e865f15ef60232287.tar.bz2
master-31e0f0ae-5e4789671ae4ecd9d2eb239e865f15ef60232287.zip
build: add support for declaring package CONFLICTS which only affect selecting built-in packages
Signed-off-by: Felix Fietkau <nbd@openwrt.org> SVN-Revision: 42770
Diffstat (limited to 'include')
-rw-r--r--include/package-defaults.mk1
-rw-r--r--include/package-dumpinfo.mk1
2 files changed, 2 insertions, 0 deletions
diff --git a/include/package-defaults.mk b/include/package-defaults.mk
index 19f2a16045..6a345b6fb9 100644
--- a/include/package-defaults.mk
+++ b/include/package-defaults.mk
@@ -19,6 +19,7 @@ define Package/Default
CATEGORY:=Extra packages
DEPENDS:=
MDEPENDS:=
+ CONFLICTS:=
PROVIDES:=
EXTRA_DEPENDS:=
MAINTAINER:=$(PKG_MAINTAINER)
diff --git a/include/package-dumpinfo.mk b/include/package-dumpinfo.mk
index 5d1d76fee5..26c8d3199d 100644
--- a/include/package-dumpinfo.mk
+++ b/include/package-dumpinfo.mk
@@ -31,6 +31,7 @@ $(if $(MENU),Menu: $(MENU)
)$(if $(findstring $(PREREQ_CHECK),1),Prereq-Check: 1
)Version: $(VERSION)
Depends: $(call PKG_FIXUP_DEPENDS,$(1),$(DEPENDS))
+Conflicts: $(CONFLICTS)
Menu-Depends: $(MDEPENDS)
Provides: $(PROVIDES)
$(if $(VARIANT),Build-Variant: $(VARIANT)