summaryrefslogtreecommitdiffstats
path: root/include
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2016-07-22 12:10:17 +0200
committerFelix Fietkau <nbd@nbd.name>2016-07-29 10:18:26 +0200
commit5d30bf83039aa1089e70d8c80b6ad03ba92bfc2a (patch)
tree101ad64ef54238bba17043bb4d6b8423bff6a2bb /include
parent37e82e4e42155901756a67ad14f3d5c1335f3b0a (diff)
downloadmaster-31e0f0ae-5d30bf83039aa1089e70d8c80b6ad03ba92bfc2a.tar.gz
master-31e0f0ae-5d30bf83039aa1089e70d8c80b6ad03ba92bfc2a.tar.bz2
master-31e0f0ae-5d30bf83039aa1089e70d8c80b6ad03ba92bfc2a.zip
build: rework opkg command invocation
Drop included $(XARGS), add support for passing target dir via parameter Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'include')
-rw-r--r--include/rootfs.mk8
1 files changed, 4 insertions, 4 deletions
diff --git a/include/rootfs.mk b/include/rootfs.mk
index 4b4482c213..90ee312619 100644
--- a/include/rootfs.mk
+++ b/include/rootfs.mk
@@ -34,11 +34,11 @@ ifdef CONFIG_USE_MKLIBS
endif
# where to build (and put) .ipk packages
-OPKG:= \
+opkg = \
IPKG_NO_SCRIPT=1 \
- IPKG_INSTROOT=$(TARGET_DIR) \
- $(XARGS) $(STAGING_DIR_HOST)/bin/opkg \
- --offline-root $(TARGET_DIR) \
+ IPKG_INSTROOT=$(1) \
+ $(STAGING_DIR_HOST)/bin/opkg \
+ --offline-root $(1) \
--force-depends \
--force-overwrite \
--force-postinstall \