summaryrefslogtreecommitdiffstats
path: root/include
diff options
context:
space:
mode:
authorPushpal Sidhu <psidhu@gateworks.com>2016-09-01 07:54:03 -0700
committerJohn Crispin <john@phrozen.org>2016-09-08 13:40:02 +0200
commit4fd043b95b4f1817b00a431f7c1c0836c39d8559 (patch)
treea1d9218f517ae560de3c84191aab6fa7bd5e4426 /include
parent42f559ed70897a7b74dd3e6293b42e6d2e511eaa (diff)
downloadmaster-31e0f0ae-4fd043b95b4f1817b00a431f7c1c0836c39d8559.tar.gz
master-31e0f0ae-4fd043b95b4f1817b00a431f7c1c0836c39d8559.tar.bz2
master-31e0f0ae-4fd043b95b4f1817b00a431f7c1c0836c39d8559.zip
image.mk: Create a manifest file of installed packages as a build artifact
A few linux BSP's create a manifest file of installed packages for a given target in order to help them understand exactly what's on their images. Create one here as well as a build artifact since many users have an affinity to prune down on packages to save valuable flash space. Signed-off-by: Pushpal Sidhu <psidhu@gateworks.com> Signed-off-by: Tim Harvey <tharvey@gateworks.com>
Diffstat (limited to 'include')
-rw-r--r--include/image.mk8
1 files changed, 8 insertions, 0 deletions
diff --git a/include/image.mk b/include/image.mk
index 7079f18786..bab7f533a2 100644
--- a/include/image.mk
+++ b/include/image.mk
@@ -264,6 +264,13 @@ define Image/mkfs/prepare
$(call Image/mkfs/prepare/default,$(1))
endef
+define Image/Manifest
+ $(STAGING_DIR_HOST)/bin/opkg \
+ --offline-root $(TARGET_DIR) \
+ --add-arch all:100 \
+ --add-arch $(if $(ARCH_PACKAGES),$(ARCH_PACKAGES),$(BOARD)):200 list-installed > \
+ $(BIN_DIR)/$(IMG_PREFIX)$(if $(PROFILE_SANITIZED),-$(PROFILE_SANITIZED)).manifest
+endef
ifdef CONFIG_TARGET_ROOTFS_TARGZ
define Image/Build/targz
@@ -565,5 +572,6 @@ define BuildImage
$(MAKE) legacy-images
install: install-images
+ $(call Image/Manifest)
endef