summaryrefslogtreecommitdiffstats
path: root/include
diff options
context:
space:
mode:
authorJohn Crispin <john@phrozen.org>2016-08-03 02:30:12 +0200
committerJohn Crispin <john@phrozen.org>2016-08-03 15:30:13 +0200
commit4df20117943dcc5dab6705e8dad7a6cfbc30dfb0 (patch)
tree6ef15f10516fc6a64ba830cc6e6c27293d5dd1de /include
parent8e75630d1d04fd27b4a8f5ad7c1619d4c6a6eed7 (diff)
downloadmaster-31e0f0ae-4df20117943dcc5dab6705e8dad7a6cfbc30dfb0.tar.gz
master-31e0f0ae-4df20117943dcc5dab6705e8dad7a6cfbc30dfb0.tar.bz2
master-31e0f0ae-4df20117943dcc5dab6705e8dad7a6cfbc30dfb0.zip
include/image.mk: allow image code to override uImage name
Signed-off-by: John Crispin <john@phrozen.org>
Diffstat (limited to 'include')
-rw-r--r--include/image-commands.mk2
-rw-r--r--include/image.mk3
2 files changed, 3 insertions, 2 deletions
diff --git a/include/image-commands.mk b/include/image-commands.mk
index 160b5d8833..00cb3410e9 100644
--- a/include/image-commands.mk
+++ b/include/image-commands.mk
@@ -7,7 +7,7 @@ define Build/uImage
mkimage -A $(LINUX_KARCH) \
-O linux -T kernel \
-C $(1) -a $(KERNEL_LOADADDR) -e $(if $(KERNEL_ENTRY),$(KERNEL_ENTRY),$(KERNEL_LOADADDR)) \
- -n '$(call toupper,$(LINUX_KARCH)) LEDE Linux-$(LINUX_VERSION)' -d $@ $@.new
+ -n '$(if $(UIMAGE_NAME),$(UIMAGE_NAME),$(call toupper,$(LINUX_KARCH)) LEDE Linux-$(LINUX_VERSION))' -d $@ $@.new
@mv $@.new $@
endef
diff --git a/include/image.mk b/include/image.mk
index 91862c42a5..f0b25aa763 100644
--- a/include/image.mk
+++ b/include/image.mk
@@ -355,6 +355,7 @@ define Device/Init
DEVICE_DTS_DIR :=
BOARD_NAME :=
+ UIMAGE_NAME :=
FILESYSTEMS := $(TARGET_FILESYSTEMS)
endef
@@ -364,7 +365,7 @@ DEFAULT_DEVICE_VARS := \
DEVICE_DTS DEVICE_DTS_DIR BOARD_NAME CMDLINE \
UBOOTENV_IN_UBI KERNEL_IN_UBI \
BLOCKSIZE PAGESIZE SUBPAGESIZE VID_HDR_OFFSET \
- UBINIZE_OPTS
+ UBINIZE_OPTS UIMAGE_NAME
define Device/ExportVar
$(1) : $(2):=$$($(2))