summaryrefslogtreecommitdiffstats
path: root/include
diff options
context:
space:
mode:
authorMathias Kresin <dev@kresin.me>2016-09-04 08:51:58 +0200
committerMathias Kresin <dev@kresin.me>2016-09-04 08:51:58 +0200
commit3e7524c184d147de6b0c8154c5c4f4019993922f (patch)
treed1bba9edef43a0c48ac58ab1b2df7e5c38aaff9c /include
parentb99a93ebaf0dc34ab0de452e3034b28f21085988 (diff)
downloadmaster-31e0f0ae-3e7524c184d147de6b0c8154c5c4f4019993922f.tar.gz
master-31e0f0ae-3e7524c184d147de6b0c8154c5c4f4019993922f.tar.bz2
master-31e0f0ae-3e7524c184d147de6b0c8154c5c4f4019993922f.zip
image: add support for k unit suffix to append-ubi
Allows to use the same unit for all definitions of the blocksize to be consistent regardless of the used filesystem. Signed-off-by: Mathias Kresin <dev@kresin.me>
Diffstat (limited to 'include')
-rw-r--r--include/image-commands.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/image-commands.mk b/include/image-commands.mk
index 3b9ea3ccba..6cb5bff4ab 100644
--- a/include/image-commands.mk
+++ b/include/image-commands.mk
@@ -117,7 +117,7 @@ define Build/append-ubi
$(foreach part,$(UBINIZE_PARTS),--part $(part)) \
$(IMAGE_ROOTFS) \
$@.tmp \
- -p $(BLOCKSIZE) -m $(PAGESIZE) \
+ -p $(BLOCKSIZE:%k=%KiB) -m $(PAGESIZE) \
$(if $(SUBPAGESIZE),-s $(SUBPAGESIZE)) \
$(if $(VID_HDR_OFFSET),-O $(VID_HDR_OFFSET)) \
$(UBINIZE_OPTS)