summaryrefslogtreecommitdiffstats
path: root/include
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-03-16 03:02:31 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-03-16 03:02:31 +0000
commit2c62bddcfe20dc4691d13995bfe8c6e3d869d62f (patch)
tree1d41250dcc9cac9ed489fecf0f3eb42b8ecc69bb /include
parent7b1a36cab40624bc52a6475633d06cfb4ba11527 (diff)
downloadmaster-31e0f0ae-2c62bddcfe20dc4691d13995bfe8c6e3d869d62f.tar.gz
master-31e0f0ae-2c62bddcfe20dc4691d13995bfe8c6e3d869d62f.tar.bz2
master-31e0f0ae-2c62bddcfe20dc4691d13995bfe8c6e3d869d62f.zip
Add an 'Image Configuration' menu to menuconfig Packages can export a list of config options with labels and data types through the metadata. The selected config values will be exported to the target filesystem in /etc/uci-defaults and applied on the first boot.
SVN-Revision: 6572
Diffstat (limited to 'include')
-rw-r--r--include/package-dumpinfo.mk7
-rw-r--r--include/package-ipkg.mk14
2 files changed, 14 insertions, 7 deletions
diff --git a/include/package-dumpinfo.mk b/include/package-dumpinfo.mk
index 2d52f23475..e6a462863c 100644
--- a/include/package-dumpinfo.mk
+++ b/include/package-dumpinfo.mk
@@ -6,7 +6,11 @@
#
ifneq ($(DUMP),)
-define Dumpinfo
+define Config
+ preconfig_$$(1) += echo "Preconfig: $(1)"; echo "Preconfig-Type: $(2)"; echo "Preconfig-Default: $(3)"; echo "Preconfig-Label: $(4)";
+endef
+
+define Dumpinfo
dumpinfo: dumpinfo-$(1)
dumpinfo-$(1): FORCE
@echo "Package: $(1)" ; \
@@ -28,5 +32,6 @@ define Dumpinfo
$(if $(URL),echo;echo "$(URL)";) \
echo "@@" ; \
$$(if $$(Package/$(1)/config),echo "Config: "; getvar $(call shvar,Package/$(1)/config); echo "@@")
+ $(if $$(preconfig_$(1)),@$$(preconfig_$(1)) echo "")
endef
endif
diff --git a/include/package-ipkg.mk b/include/package-ipkg.mk
index 0d6ab8af91..0f98dcfe14 100644
--- a/include/package-ipkg.mk
+++ b/include/package-ipkg.mk
@@ -54,12 +54,14 @@ define BuildIPKG
done; \
echo "Depends: $$$$DEPENDS" >> $$(IDIR_$(1))/CONTROL/control; \
)
- echo "Source: $(SOURCE)" >> $$(IDIR_$(1))/CONTROL/control
- echo "Section: $(SECTION)" >> $$(IDIR_$(1))/CONTROL/control
- echo "Priority: $(PRIORITY)" >> $$(IDIR_$(1))/CONTROL/control
- echo "Maintainer: $(MAINTAINER)" >> $$(IDIR_$(1))/CONTROL/control
- echo "Architecture: $(PKGARCH)" >> $$(IDIR_$(1))/CONTROL/control
- echo "Description: $(DESCRIPTION)" | sed -e 's,\\,\n,g' | sed -e 's,^[[:space:]]*$$$$, .,g' >> $$(IDIR_$(1))/CONTROL/control
+ ( \
+ echo "Source: $(SOURCE)"; \
+ echo "Section: $(SECTION)"; \
+ echo "Priority: $(PRIORITY)"; \
+ echo "Maintainer: $(MAINTAINER)"; \
+ echo "Architecture: $(PKGARCH)"; \
+ echo -n "Description: "; getvar $(call shvar,Package/$(1)/description) | sed -e 's,^[[:space:]]*, ,g'; \
+ ) >> $$(IDIR_$(1))/CONTROL/control
chmod 644 $$(IDIR_$(1))/CONTROL/control
(cd $$(IDIR_$(1))/CONTROL; \
$($(1)_COMMANDS) \