summaryrefslogtreecommitdiffstats
path: root/include
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2016-08-04 11:12:27 +0200
committerFelix Fietkau <nbd@nbd.name>2016-08-04 11:19:41 +0200
commit2180b715c1dcef30cb8e734c42b7e24f5f6555e5 (patch)
tree2c9d3598dfdc2dd2800d024f3acff333dda535e8 /include
parent9bfa6971aeaa663ae5cc845f589ebbd1459a1fc9 (diff)
downloadmaster-31e0f0ae-2180b715c1dcef30cb8e734c42b7e24f5f6555e5.tar.gz
master-31e0f0ae-2180b715c1dcef30cb8e734c42b7e24f5f6555e5.tar.bz2
master-31e0f0ae-2180b715c1dcef30cb8e734c42b7e24f5f6555e5.zip
image: fix per-device rootfs build error when not all opkg package files are found
Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'include')
-rw-r--r--include/image.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/image.mk b/include/image.mk
index f0b25aa763..c85a9d6505 100644
--- a/include/image.mk
+++ b/include/image.mk
@@ -294,7 +294,7 @@ target-dir-%: FORCE
$(CP) $(TARGET_DIR) $(mkfs_cur_target_dir)
mv $(mkfs_cur_target_dir)/etc/opkg $(mkfs_cur_target_dir).opkg
echo 'src default file://$(PACKAGE_DIR_ALL)' > $(mkfs_cur_target_dir).conf
- $(if $(mkfs_packages_add), \
+ $(if $(call opkg_package_files,$(mkfs_packages_add)), \
$(opkg_target) update && \
$(opkg_target) install \
$(call opkg_package_files,$(mkfs_packages_add)))