summaryrefslogtreecommitdiffstats
path: root/include
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2013-03-07 17:32:29 +0000
committerFelix Fietkau <nbd@openwrt.org>2013-03-07 17:32:29 +0000
commit1f77bfff9608f97996bffdb28dabec4e787631f6 (patch)
tree9e624ddb58dffe5cae5af0ea17b7bd51116e3418 /include
parented083586aaf8468794c87d65324cfe7ee015f38c (diff)
downloadmaster-31e0f0ae-1f77bfff9608f97996bffdb28dabec4e787631f6.tar.gz
master-31e0f0ae-1f77bfff9608f97996bffdb28dabec4e787631f6.tar.bz2
master-31e0f0ae-1f77bfff9608f97996bffdb28dabec4e787631f6.zip
build: BSD compile fixes
following patch allows to build images for Qemu ARM on OpenBSD 5.2 amd64 and FreeBSD 9.1 amd64. Mostly small pieces of code changes to get things right on the specific platform. Updated the README to describe better, which tools on the host are required. Added some kind of prepare scripts to install needed tools on BSD via packages. Signed-off-by: Waldemar Brodkorb <mail@waldemar-brodkorb.de> SVN-Revision: 35900
Diffstat (limited to 'include')
-rw-r--r--include/host-build.mk2
-rw-r--r--include/host.mk3
-rw-r--r--include/prereq-build.mk8
3 files changed, 7 insertions, 6 deletions
diff --git a/include/host-build.mk b/include/host-build.mk
index 320e74ee47..126671a0b3 100644
--- a/include/host-build.mk
+++ b/include/host-build.mk
@@ -71,7 +71,7 @@ HOST_CONFIGURE_ARGS = \
HOST_MAKE_FLAGS =
-HOST_CONFIGURE_CMD = ./configure
+HOST_CONFIGURE_CMD = $(BASH) ./configure
ifneq ($(HOST_OS),Darwin)
ifeq ($(CONFIG_BUILD_STATIC_TOOLS),y)
diff --git a/include/host.mk b/include/host.mk
index 9b8a32b672..b44c1bf1ac 100644
--- a/include/host.mk
+++ b/include/host.mk
@@ -62,6 +62,9 @@ $(TMP_DIR)/.host.mk: $(TOPDIR)/include/host.mk
PATCH=`which gpatch 2>/dev/null`; \
[ -n "$$PATCH" -a -x "$$PATCH" ] || PATCH=`which patch 2>/dev/null`; \
echo "PATCH:=$$PATCH" >> $@; \
+ PYTHON=`which python2.7 2>/dev/null`; \
+ [ -n "$$PYTHON" -a -x "$$PYTHON" ] || PYTHON=`which python 2>/dev/null`; \
+ echo "PYTHON:=$$PYTHON" >> $@; \
)
endif
diff --git a/include/prereq-build.mk b/include/prereq-build.mk
index c7d59f1202..59ea7ef9a7 100644
--- a/include/prereq-build.mk
+++ b/include/prereq-build.mk
@@ -39,6 +39,8 @@ $(eval $(call Require,case-sensitive-fs, \
))
define Require/getopt
+ gnugetopt --help 2>&1 | grep long >/dev/null || \
+ /usr/local/bin/getopt --help 2>&1 | grep long >/dev/null || \
getopt --help 2>&1 | grep long >/dev/null
endef
$(eval $(call Require,getopt, \
@@ -134,15 +136,11 @@ $(eval $(call RequireCommand,bzip2, \
Please install bzip2. \
))
-$(eval $(call RequireCommand,patch, \
- Please install patch. \
-))
-
$(eval $(call RequireCommand,perl, \
Please install perl. \
))
-$(eval $(call RequireCommand,python, \
+$(eval $(call RequireCommand,$(PYTHON), \
Please install python. \
))