summaryrefslogtreecommitdiffstats
path: root/include
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2016-07-31 12:38:01 +0200
committerFelix Fietkau <nbd@nbd.name>2016-07-31 12:45:18 +0200
commit14488469d5aae0406b623426fac14f18e33e5d5c (patch)
treef3a80b3bec3a1e7e5b93627476ff8395979c55ce /include
parent5e41c1d447ec4e064b3151d9b88f5a4aaeecbfd2 (diff)
downloadmaster-31e0f0ae-14488469d5aae0406b623426fac14f18e33e5d5c.tar.gz
master-31e0f0ae-14488469d5aae0406b623426fac14f18e33e5d5c.tar.bz2
master-31e0f0ae-14488469d5aae0406b623426fac14f18e33e5d5c.zip
image: fix build issue with per-device rootfs and legacy devices
Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'include')
-rw-r--r--include/image-legacy.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/image-legacy.mk b/include/image-legacy.mk
index 9633500fd9..9960caba0c 100644
--- a/include/image-legacy.mk
+++ b/include/image-legacy.mk
@@ -65,7 +65,7 @@ define LegacyDevice/Build
ifndef IB
ifdef CONFIG_TARGET_PER_DEVICE_ROOTFS
ROOTFS/$(1) := $(foreach fs,$(TARGET_FILESYSTEMS), \
- $(KDIR)/root.$(fs)$$(strip $(if $(CONFIG_TARGET_PER_DEVICE_ROOTFS),+pkg=$$(ROOTFS_ID/$(1))))
+ $(KDIR)/root.$(fs)$$(strip $(if $(CONFIG_TARGET_PER_DEVICE_ROOTFS),+pkg=$$(ROOTFS_ID/$(1)))) \
)
$$(ROOTFS/$(1)): target-dir-$$(ROOTFS_ID/$(1))