summaryrefslogtreecommitdiffstats
path: root/include
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2006-10-18 13:16:44 +0000
committerNicolas Thill <nico@openwrt.org>2006-10-18 13:16:44 +0000
commitee11bee3909aeaa86709ca54e25be2c9f7b099fa (patch)
treec80e6b950e4adb257288112876d0929db91147b9 /include
parent454f20488d759c806c2cf6e0c1c14be6ae9a703f (diff)
downloadmaster-31e0f0ae-ee11bee3909aeaa86709ca54e25be2c9f7b099fa.tar.gz
master-31e0f0ae-ee11bee3909aeaa86709ca54e25be2c9f7b099fa.tar.bz2
master-31e0f0ae-ee11bee3909aeaa86709ca54e25be2c9f7b099fa.zip
fix uml-2.6 build, move KERNELNAME to kernel-build.mk
SVN-Revision: 5204
Diffstat (limited to 'include')
-rw-r--r--include/kernel-build.mk16
-rw-r--r--include/kernel.mk9
2 files changed, 14 insertions, 11 deletions
diff --git a/include/kernel-build.mk b/include/kernel-build.mk
index 06f4ce7726..a3c714c688 100644
--- a/include/kernel-build.mk
+++ b/include/kernel-build.mk
@@ -18,13 +18,25 @@ KERNEL_IPKG:=$(KERNEL_BUILD_DIR)/kernel_$(LINUX_VERSION)-$(BOARD)-$(LINUX_RELEAS
TARGETS += $(KERNEL_IPKG)
INSTALL_TARGETS += $(KERNEL_IPKG)
-LINUX_KARCH:=$(shell echo $(ARCH) | sed -e 's/i[3-9]86/i386/' \
+ifneq (,$(findstring uml,$(BOARD)))
+ LINUX_KARCH:=um
+else
+ LINUX_KARCH:=$(shell echo $(ARCH) | sed -e 's/i[3-9]86/i386/' \
-e 's/mipsel/mips/' \
-e 's/mipseb/mips/' \
-e 's/powerpc/ppc/' \
-e 's/sh[234]/sh/' \
-e 's/armeb/arm/' \
-)
+ )
+endif
+
+KERNELNAME=
+ifneq (,$(findstring x86,$(BOARD)))
+ KERNELNAME="bzImage"
+endif
+ifneq (,$(findstring ppc,$(BOARD)))
+ KERNELNAME="uImage"
+endif
$(TARGETS): $(PACKAGE_DIR)
diff --git a/include/kernel.mk b/include/kernel.mk
index 7c0ba6d7dd..7a36cee1a5 100644
--- a/include/kernel.mk
+++ b/include/kernel.mk
@@ -31,16 +31,7 @@ else
LINUX_KMOD_SUFFIX=o
endif
- KERNELNAME=
- ifneq (,$(findstring x86,$(BOARD)))
- KERNELNAME="bzImage"
- endif
- ifneq (,$(findstring ppc,$(BOARD)))
- KERNELNAME="uImage"
- endif
-
ifneq (,$(findstring uml,$(BOARD)))
- LINUX_KARCH:=um
KERNEL_CC:=$(HOSTCC)
KERNEL_CROSS:=
else