summaryrefslogtreecommitdiffstats
path: root/include
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2007-10-03 19:22:51 +0000
committerGabor Juhos <juhosg@openwrt.org>2007-10-03 19:22:51 +0000
commite12359aa29fcb7c3adc97264bcdc48b10c0472ec (patch)
treea7b20a24ef1cb183159a7c0f3ac0295c74c98290 /include
parentf1593e5c2845f861d537d227808b12253be6caa2 (diff)
downloadmaster-31e0f0ae-e12359aa29fcb7c3adc97264bcdc48b10c0472ec.tar.gz
master-31e0f0ae-e12359aa29fcb7c3adc97264bcdc48b10c0472ec.tar.bz2
master-31e0f0ae-e12359aa29fcb7c3adc97264bcdc48b10c0472ec.zip
fix target profiles, (closes: 2440)
SVN-Revision: 9113
Diffstat (limited to 'include')
-rw-r--r--include/target.mk20
1 files changed, 16 insertions, 4 deletions
diff --git a/include/target.mk b/include/target.mk
index 1f17883ab1..0217fcff6f 100644
--- a/include/target.mk
+++ b/include/target.mk
@@ -1,4 +1,4 @@
-#
+#
# Copyright (C) 2007 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
@@ -75,10 +75,22 @@ define Profile
endif
endef
-ifeq ($(if $(TARGET_BUILD),$(DUMP)),1)
- -include $(PLATFORM_DIR)/profiles/*.mk
- ifneq ($(PLATFORM_DIR),$(PLATFORM_SUBDIR))
+ifneq ($(PLATFORM_DIR),$(PLATFORM_SUBDIR))
+ define IncludeProfiles
+ -include $(PLATFORM_DIR)/profiles/*.mk
-include $(PLATFORM_SUBDIR)/profiles/*.mk
+ endef
+else
+ define IncludeProfiles
+ -include $(PLATFORM_DIR)/profiles/*.mk
+ endef
+endif
+
+ifeq ($(TARGET_BUILD),1)
+ $(eval $(call IncludeProfiles))
+else
+ ifeq ($(DUMP),)
+ $(eval $(call IncludeProfiles))
endif
endif