summaryrefslogtreecommitdiffstats
path: root/include
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-11-14 23:11:07 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-11-14 23:11:07 +0000
commitdfa7618bd6a9efbbd98260917f67741555d3b8a2 (patch)
tree481f39346df046ee332a8abe55a0850d652bb618 /include
parent874935fe41d7a7197949da85d565794ed9279213 (diff)
downloadmaster-31e0f0ae-dfa7618bd6a9efbbd98260917f67741555d3b8a2.tar.gz
master-31e0f0ae-dfa7618bd6a9efbbd98260917f67741555d3b8a2.tar.bz2
master-31e0f0ae-dfa7618bd6a9efbbd98260917f67741555d3b8a2.zip
fix the image builder
SVN-Revision: 9549
Diffstat (limited to 'include')
-rw-r--r--include/kernel-defaults.mk16
-rw-r--r--include/target.mk24
2 files changed, 21 insertions, 19 deletions
diff --git a/include/kernel-defaults.mk b/include/kernel-defaults.mk
index 4b25f544a2..69ff8fa6f0 100644
--- a/include/kernel-defaults.mk
+++ b/include/kernel-defaults.mk
@@ -5,22 +5,6 @@
# See /LICENSE for more information.
#
-# default device type
-DEVICE_TYPE?=router
-
-# Default packages - the really basic set
-DEFAULT_PACKAGES:=base-files libgcc uclibc busybox dropbear mtd mtd
-# For router targets
-DEFAULT_PACKAGES.router:=dnsmasq iptables ppp ppp-mod-pppoe iptables kmod-ipt-nathelper bridge
-
-# Additional packages for Linux 2.6
-ifneq ($(KERNEL),2.4)
- DEFAULT_PACKAGES += udevtrigger hotplug2
-endif
-
-# Add device specific packages
-DEFAULT_PACKAGES += $(DEFAULT_PACKAGES.$(DEVICE_TYPE))
-
KERNELNAME=
ifneq (,$(findstring x86,$(BOARD)))
KERNELNAME="bzImage"
diff --git a/include/target.mk b/include/target.mk
index 757d178ab3..09a3f79af9 100644
--- a/include/target.mk
+++ b/include/target.mk
@@ -5,13 +5,29 @@
# See /LICENSE for more information.
#
+ifneq ($(__target_inc),1)
+__target_inc=1
+
+# default device type
+DEVICE_TYPE?=router
+
+# Default packages - the really basic set
+DEFAULT_PACKAGES:=base-files libgcc uclibc busybox dropbear mtd mtd
+# For router targets
+DEFAULT_PACKAGES.router:=dnsmasq iptables ppp ppp-mod-pppoe iptables kmod-ipt-nathelper bridge
+
+# Additional packages for Linux 2.6
+ifneq ($(KERNEL),2.4)
+ DEFAULT_PACKAGES += udevtrigger hotplug2
+endif
+
+# Add device specific packages
+DEFAULT_PACKAGES += $(DEFAULT_PACKAGES.$(DEVICE_TYPE))
+
ifneq ($(DUMP),)
all: dumpinfo
endif
-ifneq ($(__target_inc),1)
-__target_inc=1
-
target_conf=$(subst .,_,$(subst -,_,$(subst /,_,$(1))))
ifeq ($(DUMP),)
PLATFORM_DIR:=$(TOPDIR)/target/linux/$(BOARD)
@@ -39,6 +55,7 @@ define Profile/Default
PACKAGES:=
endef
+ifndef Profile
define Profile
$(eval $(call Profile/Default))
$(eval $(call Profile/$(1)))
@@ -62,6 +79,7 @@ define Profile
PROFILE=$(1)
endif
endef
+endif
ifneq ($(PLATFORM_DIR),$(PLATFORM_SUBDIR))
define IncludeProfiles