summaryrefslogtreecommitdiffstats
path: root/include
diff options
context:
space:
mode:
authorJo-Philipp Wich <jo@mein.io>2016-04-22 12:02:53 +0200
committerJo-Philipp Wich <jo@mein.io>2016-04-22 12:02:53 +0200
commitd9ad55a6091eb5de77095f6217578396fc7a938b (patch)
tree7a53d15daf17e9ebb905209fe2a4c2926e42048a /include
parent37de17c379a7272dcfb5d4d2a411687207b5c78d (diff)
downloadmaster-31e0f0ae-d9ad55a6091eb5de77095f6217578396fc7a938b.tar.gz
master-31e0f0ae-d9ad55a6091eb5de77095f6217578396fc7a938b.tar.bz2
master-31e0f0ae-d9ad55a6091eb5de77095f6217578396fc7a938b.zip
include: remove unused FeedPackageDir macro arguments
Signed-off-by: Jo-Philipp Wich <jo@mein.io>
Diffstat (limited to 'include')
-rw-r--r--include/feeds.mk2
-rw-r--r--include/package-ipkg.mk2
2 files changed, 1 insertions, 3 deletions
diff --git a/include/feeds.mk b/include/feeds.mk
index a5ce877967..d0d473983e 100644
--- a/include/feeds.mk
+++ b/include/feeds.mk
@@ -30,8 +30,6 @@ PKG_CONFIG_DEPENDS += \
$(foreach feed,$(FEEDS_INSTALLED),CONFIG_FEED_$(feed))
# 1: package name
-# 2: flags
-# 3: section
define FeedPackageDir
$(strip $(if $(CONFIG_PER_FEED_REPO), \
$(if $(Package/$(1)/subdir), \
diff --git a/include/package-ipkg.mk b/include/package-ipkg.mk
index a86f401805..eb4c874047 100644
--- a/include/package-ipkg.mk
+++ b/include/package-ipkg.mk
@@ -88,7 +88,7 @@ _endef=endef
ifeq ($(DUMP),)
define BuildTarget/ipkg
- PDIR_$(1):=$(call FeedPackageDir,$(1),$(PKG_FLAGS),$(SECTION))
+ PDIR_$(1):=$(call FeedPackageDir,$(1))
IPKG_$(1):=$$(PDIR_$(1))/$(1)_$(VERSION)_$(PKGARCH).ipk
IDIR_$(1):=$(PKG_BUILD_DIR)/ipkg-$(PKGARCH)/$(1)
KEEP_$(1):=$(strip $(call Package/$(1)/conffiles))