summaryrefslogtreecommitdiffstats
path: root/include
diff options
context:
space:
mode:
authorMichael Büsch <mb@bu3sch.de>2010-10-03 12:54:07 +0000
committerMichael Büsch <mb@bu3sch.de>2010-10-03 12:54:07 +0000
commitcf323eb924bf6a5b45e136f7afef91078d5b070d (patch)
tree7b350cd2d188252969c030ec46477ae3659f812c /include
parent68219be4e76133e9d3cff8e76d0e66232efbf593 (diff)
downloadmaster-31e0f0ae-cf323eb924bf6a5b45e136f7afef91078d5b070d.tar.gz
master-31e0f0ae-cf323eb924bf6a5b45e136f7afef91078d5b070d.tar.bz2
master-31e0f0ae-cf323eb924bf6a5b45e136f7afef91078d5b070d.zip
optionally support parallel toolchain build. This defaults to off, because certain toolchain versions are known to break on parallel build. However, it significantly speeds up the build and latest versions of the tools do compile fine.
SVN-Revision: 23196
Diffstat (limited to 'include')
-rw-r--r--include/toolchain-build.mk2
1 files changed, 2 insertions, 0 deletions
diff --git a/include/toolchain-build.mk b/include/toolchain-build.mk
index 6defe63edf..a0bc4061fc 100644
--- a/include/toolchain-build.mk
+++ b/include/toolchain-build.mk
@@ -11,6 +11,8 @@ REAL_STAGING_DIR_HOST:=$(STAGING_DIR_HOST)
STAGING_DIR_HOST:=$(TOOLCHAIN_DIR)
BUILD_DIR_HOST:=$(BUILD_DIR_TOOLCHAIN)
+TOOLCHAIN_JOBS?=$(if $(CONFIG_TOOLCHAIN_PARALLEL),-j$(CONFIG_PKG_BUILD_JOBS))
+
include $(INCLUDE_DIR)/host-build.mk
HOST_STAMP_PREPARED=$(HOST_BUILD_DIR)/.prepared