summaryrefslogtreecommitdiffstats
path: root/include
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-12-19 11:15:41 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-12-19 11:15:41 +0000
commitcaf3a14a3cbdb028013078c67fac3dcc03f1a93b (patch)
tree136a1613928b4f51d605a3c605371184a4d245b0 /include
parent3e807886d0edd224584a507683ed7cdaea937e5a (diff)
downloadmaster-31e0f0ae-caf3a14a3cbdb028013078c67fac3dcc03f1a93b.tar.gz
master-31e0f0ae-caf3a14a3cbdb028013078c67fac3dcc03f1a93b.tar.bz2
master-31e0f0ae-caf3a14a3cbdb028013078c67fac3dcc03f1a93b.zip
image.mk: use cross toolchain cpp for processing dts file instead of relying on the host compiler
Signed-off-by: Felix Fietkau <nbd@openwrt.org> SVN-Revision: 47937
Diffstat (limited to 'include')
-rw-r--r--include/image.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/image.mk b/include/image.mk
index 6b2fb1afd8..1522dd72c8 100644
--- a/include/image.mk
+++ b/include/image.mk
@@ -142,7 +142,7 @@ endef
# $(3) extra CPP flags
# $(4) extra DTC flags
define Image/BuildDTB
- $(CPP) -nostdinc -x assembler-with-cpp \
+ $(TARGET_CROSS)cpp -nostdinc -x assembler-with-cpp \
-I$(DTS_DIR) \
-I$(DTS_DIR)/include \
-undef -D__DTS__ $(3) \