summaryrefslogtreecommitdiffstats
path: root/include
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2007-08-21 18:07:55 +0000
committerNicolas Thill <nico@openwrt.org>2007-08-21 18:07:55 +0000
commitba05b57573eaf3272997892eb521451b670c4d5e (patch)
tree3daec9dea8fdd596605e067e026a6f6dfff8d47d /include
parente6ee25ebd08bdf046a7617ee46a84fd370092ee2 (diff)
downloadmaster-31e0f0ae-ba05b57573eaf3272997892eb521451b670c4d5e.tar.gz
master-31e0f0ae-ba05b57573eaf3272997892eb521451b670c4d5e.tar.bz2
master-31e0f0ae-ba05b57573eaf3272997892eb521451b670c4d5e.zip
rename 'stampfiles' directory to 'stamp'
SVN-Revision: 8455
Diffstat (limited to 'include')
-rw-r--r--include/package.mk8
-rw-r--r--include/subdir.mk2
2 files changed, 5 insertions, 5 deletions
diff --git a/include/package.mk b/include/package.mk
index 4ef3489294..1691e68958 100644
--- a/include/package.mk
+++ b/include/package.mk
@@ -67,9 +67,9 @@ define Build/DefaultTargets
touch $$@
ifdef Build/InstallDev
- compile: $(STAGING_DIR)/stampfiles/.$(PKG_NAME)-installed
- $(STAGING_DIR)/stampfiles/.$(PKG_NAME)-installed: $(STAMP_BUILT)
- mkdir -p $(STAGING_DIR)/stampfiles
+ compile: $(STAGING_DIR)/stamp/.$(PKG_NAME)-installed
+ $(STAGING_DIR)/stamp/.$(PKG_NAME)-installed: $(STAMP_BUILT)
+ mkdir -p $(STAGING_DIR)/stamp
$(Build/InstallDev)
touch $$@
endif
@@ -128,5 +128,5 @@ install:
clean: FORCE
$(Build/UninstallDev)
$(Build/Clean)
- @rm -f $(STAGING_DIR)/stampfiles/.$(PKG_NAME)-installed
+ @rm -f $(STAGING_DIR)/stamp/.$(PKG_NAME)-installed
@rm -rf $(PKG_BUILD_DIR)
diff --git a/include/subdir.mk b/include/subdir.mk
index 28b01b6370..217d6bc376 100644
--- a/include/subdir.mk
+++ b/include/subdir.mk
@@ -36,7 +36,7 @@ endef
# Parameters: <subdir> <name> <target>
define stampfile
- $(1)/stamp-$(3):=$(STAGING_DIR)/stampfiles/.$(2)_$(3)
+ $(1)/stamp-$(3):=$(STAGING_DIR)/stamp/.$(2)_$(3)
$(if $(__rdep_$(1)),,
$(call rdep,$(1),$$($(1)/stamp-$(3)),)
__rdep_$(1):=1