summaryrefslogtreecommitdiffstats
path: root/include
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2015-01-22 13:13:09 +0000
committerJohn Crispin <john@openwrt.org>2015-01-22 13:13:09 +0000
commitb6f268d775c8b7986667ccb685f985dcdf425cb0 (patch)
tree183c700e61fa679b63ed9da772f4be07e120ee07 /include
parentae70358b1b0dc6b5881ad931213e00793d8df9c2 (diff)
downloadmaster-31e0f0ae-b6f268d775c8b7986667ccb685f985dcdf425cb0.tar.gz
master-31e0f0ae-b6f268d775c8b7986667ccb685f985dcdf425cb0.tar.bz2
master-31e0f0ae-b6f268d775c8b7986667ccb685f985dcdf425cb0.zip
build: revert r44076
the patch causes issues when installing feeds Signed-off-by: John Crispin <blogic@openwrt.org> SVN-Revision: 44078
Diffstat (limited to 'include')
-rw-r--r--include/scan.awk17
-rw-r--r--include/scan.mk2
2 files changed, 1 insertions, 18 deletions
diff --git a/include/scan.awk b/include/scan.awk
deleted file mode 100644
index 39b2977228..0000000000
--- a/include/scan.awk
+++ /dev/null
@@ -1,17 +0,0 @@
-BEGIN { FS="/" }
-$1 ~ /^feeds/ { FEEDS[$NF]=$0 }
-$1 !~ /^feeds/ { PKGS[$NF]=$0 }
-END {
- # Filter-out OpenWrt packages which have a feeds equivalent
- for (pkg in PKGS)
- if (pkg in FEEDS)
- delete PKGS[pkg]
- n = asort(PKGS)
- for (i=1; i <= n; i++) {
- print PKGS[i]
- }
- n = asort(FEEDS)
- for (i=1; i <= n; i++){
- print FEEDS[i]
- }
-}
diff --git a/include/scan.mk b/include/scan.mk
index 138707db08..0998333439 100644
--- a/include/scan.mk
+++ b/include/scan.mk
@@ -43,7 +43,7 @@ endef
$(FILELIST):
rm -f $(TMP_DIR)/info/.files-$(SCAN_TARGET)-*
- $(call FIND_L, $(SCAN_DIR)) $(SCAN_EXTRA) -mindepth 1 $(if $(SCAN_DEPTH),-maxdepth $(SCAN_DEPTH)) -name Makefile | xargs grep -HE 'call (Build/DefaultTargets|Build(Package|Target)|.+Package)' | sed -e 's#^$(SCAN_DIR)/##' -e 's#/Makefile:.*##' | uniq | awk -f include/scan.awk > $@
+ $(call FIND_L, $(SCAN_DIR)) $(SCAN_EXTRA) -mindepth 1 $(if $(SCAN_DEPTH),-maxdepth $(SCAN_DEPTH)) -name Makefile | xargs grep -HE 'call (Build/DefaultTargets|Build(Package|Target)|.+Package)' | sed -e 's#^$(SCAN_DIR)/##' -e 's#/Makefile:.*##' | uniq > $@
$(TMP_DIR)/info/.files-$(SCAN_TARGET).mk: $(FILELIST)
( \