summaryrefslogtreecommitdiffstats
path: root/include
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2016-05-11 19:15:23 +0200
committerFelix Fietkau <nbd@nbd.name>2016-05-11 19:19:17 +0200
commitb0cf769008bc38f386c977f38f80de0fef098355 (patch)
tree9e24360f45cd1b8597adcaa3d6d7725b7e6e7f1d /include
parent91799d5198da67d03d3df4da4f384ace9f6e5bcc (diff)
downloadmaster-31e0f0ae-b0cf769008bc38f386c977f38f80de0fef098355.tar.gz
master-31e0f0ae-b0cf769008bc38f386c977f38f80de0fef098355.tar.bz2
master-31e0f0ae-b0cf769008bc38f386c977f38f80de0fef098355.zip
image.mk: include per-device profiles in image build profile check
Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'include')
-rw-r--r--include/image.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/include/image.mk b/include/image.mk
index ed4f8e44ea..67879b3780 100644
--- a/include/image.mk
+++ b/include/image.mk
@@ -475,8 +475,8 @@ define Device/Export
endef
define Device/Check
- _TARGET = $$(if $$(and $$(filter $(SUBTARGET),$$(SUBTARGETS)),$$(filter $(PROFILE),$$(PROFILES))),install,install-disabled)
- _COMPILE_TARGET = $$(if $(if $(IB),,$(CONFIG_IB)$$(filter $(PROFILE),$$(PROFILES))),compile,compile-disabled)
+ _TARGET = $$(if $$(and $$(filter $(SUBTARGET),$$(SUBTARGETS)),$$(filter $(PROFILE),$$(PROFILES) DEVICE_$(1))),install,install-disabled)
+ _COMPILE_TARGET = $$(if $(if $(IB),,$(CONFIG_IB)$$(filter $(PROFILE),$$(PROFILES) DEVICE_$(1))),compile,compile-disabled)
endef
ifndef IB