summaryrefslogtreecommitdiffstats
path: root/include
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-09-29 01:21:56 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-09-29 01:21:56 +0000
commit97b61354626866dd2483c2a283ab9b2bc087ac74 (patch)
tree4ca23a9af854189fb18b7e81268a7c0089890335 /include
parent03543ec4a4ee24df583843d386a7a39372865961 (diff)
downloadmaster-31e0f0ae-97b61354626866dd2483c2a283ab9b2bc087ac74.tar.gz
master-31e0f0ae-97b61354626866dd2483c2a283ab9b2bc087ac74.tar.bz2
master-31e0f0ae-97b61354626866dd2483c2a283ab9b2bc087ac74.zip
add a packaging method that installs files into a subdirectory of bin/ instead of an ipkg
SVN-Revision: 9060
Diffstat (limited to 'include')
-rw-r--r--include/package-bin.mk31
-rw-r--r--include/package-dumpinfo.mk1
-rw-r--r--include/package.mk1
3 files changed, 33 insertions, 0 deletions
diff --git a/include/package-bin.mk b/include/package-bin.mk
new file mode 100644
index 0000000000..6ee7aed621
--- /dev/null
+++ b/include/package-bin.mk
@@ -0,0 +1,31 @@
+#
+# Copyright (C) 2007 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+ifeq ($(DUMP),)
+ define BuildTarget/bin
+ ifdef Package/$(1)/install
+ ifneq ($(CONFIG_PACKAGE_$(1))$(SDK)$(DEVELOPER),)
+ compile: install-bin-$(1)
+ else
+ compile: $(1)-disabled
+ $(1)-disabled:
+ @echo "WARNING: skipping $(1) -- package not selected"
+ endif
+ endif
+
+ install-bin-$(1): $(STAMP_BUILT)
+ rm -rf $(BIN_DIR)/$(1)
+ $(INSTALL_DIR) $(BIN_DIR)/$(1)
+ $(call Package/$(1)/install,$(BIN_DIR)/$(1))
+
+ clean-$(1):
+ rm -rf $(BIN_DIR)/$(1)
+
+ clean: clean-$(1)
+ .PHONY: install-bin-$(1)
+ endef
+endif
diff --git a/include/package-dumpinfo.mk b/include/package-dumpinfo.mk
index bc075e1bc0..e29e113241 100644
--- a/include/package-dumpinfo.mk
+++ b/include/package-dumpinfo.mk
@@ -28,6 +28,7 @@ ifneq ($(DUMP),)
echo "Category: $(CATEGORY)"; \
echo "Title: $(TITLE)"; \
echo "Maintainer: $(MAINTAINER)"; \
+ echo "Type: $(if $(Package/$(1)/targets),$(Package/$(1)/targets),$(if $(PKG_TARGETS),$(PKG_TARGETS),ipkg))"; \
$(if $(KCONFIG),echo "Kernel-Config: $(KCONFIG)";) \
echo -n "Description: "; \
getvar $(call shvar,Package/$(1)/description); \
diff --git a/include/package.mk b/include/package.mk
index bf82c60458..9f45a441aa 100644
--- a/include/package.mk
+++ b/include/package.mk
@@ -25,6 +25,7 @@ include $(INCLUDE_DIR)/quilt.mk
include $(INCLUDE_DIR)/package-defaults.mk
include $(INCLUDE_DIR)/package-dumpinfo.mk
include $(INCLUDE_DIR)/package-ipkg.mk
+include $(INCLUDE_DIR)/package-bin.mk
override MAKEFLAGS=
export CONFIG_SITE:=$(INCLUDE_DIR)/site/$(REAL_GNU_TARGET_NAME)