summaryrefslogtreecommitdiffstats
path: root/include
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2009-02-22 04:37:20 +0000
committerFelix Fietkau <nbd@openwrt.org>2009-02-22 04:37:20 +0000
commit7eb15898755be46e94078faffdacd8c9b0ce66cd (patch)
tree89dc171f7b7c646be5a38ca7d7b99e1be24fa61f /include
parent6ccc1c8e3c9ad0ac95c728573c300264943d8338 (diff)
downloadmaster-31e0f0ae-7eb15898755be46e94078faffdacd8c9b0ce66cd.tar.gz
master-31e0f0ae-7eb15898755be46e94078faffdacd8c9b0ce66cd.tar.bz2
master-31e0f0ae-7eb15898755be46e94078faffdacd8c9b0ce66cd.zip
build system refactoring in preparation for allowing packages to do host-build steps
SVN-Revision: 14610
Diffstat (limited to 'include')
-rw-r--r--include/download.mk2
-rw-r--r--include/host-build.mk96
-rw-r--r--include/quilt.mk135
-rw-r--r--include/unpack.mk36
4 files changed, 151 insertions, 118 deletions
diff --git a/include/download.mk b/include/download.mk
index 0a2dd3c03f..811c42a3c3 100644
--- a/include/download.mk
+++ b/include/download.mk
@@ -5,7 +5,7 @@
# See /LICENSE for more information.
#
-DOWNLOAD_RDEP:=$(STAMP_PREPARED)
+DOWNLOAD_RDEP:=$(STAMP_PREPARED) $(HOST_STAMP_PREPARED)
# Try to guess the download method from the URL
define dl_method
diff --git a/include/host-build.mk b/include/host-build.mk
index 5622e98707..fdba1b36cb 100644
--- a/include/host-build.mk
+++ b/include/host-build.mk
@@ -5,40 +5,40 @@
# See /LICENSE for more information.
#
-PKG_BUILD_DIR ?= $(BUILD_DIR_HOST)/$(PKG_NAME)$(if $(PKG_VERSION),-$(PKG_VERSION))
-PKG_INSTALL_DIR ?= $(PKG_BUILD_DIR)/host-install
+HOST_BUILD_DIR ?= $(BUILD_DIR_HOST)/$(PKG_NAME)$(if $(PKG_VERSION),-$(PKG_VERSION))
+PKG_INSTALL_DIR ?= $(HOST_BUILD_DIR)/host-install
include $(INCLUDE_DIR)/host.mk
include $(INCLUDE_DIR)/unpack.mk
include $(INCLUDE_DIR)/depends.mk
-STAMP_PREPARED=$(PKG_BUILD_DIR)/.prepared$(if $(QUILT)$(DUMP),,$(shell $(call find_md5,${CURDIR} $(PKG_FILE_DEPEND),)))
-STAMP_CONFIGURED:=$(PKG_BUILD_DIR)/.configured
-STAMP_BUILT:=$(PKG_BUILD_DIR)/.built
-STAMP_INSTALLED:=$(STAGING_DIR_HOST)/stamp/.$(PKG_NAME)_installed
+HOST_STAMP_PREPARED=$(HOST_BUILD_DIR)/.prepared$(if $(QUILT)$(DUMP),,$(shell $(call find_md5,${CURDIR} $(PKG_FILE_DEPEND),)))
+HOST_STAMP_CONFIGURED:=$(HOST_BUILD_DIR)/.configured
+HOST_STAMP_BUILT:=$(HOST_BUILD_DIR)/.built
+HOST_STAMP_INSTALLED:=$(STAGING_DIR_HOST)/stamp/.$(PKG_NAME)_installed
override MAKEFLAGS=
include $(INCLUDE_DIR)/download.mk
include $(INCLUDE_DIR)/quilt.mk
-Build/Patch:=$(Build/Patch/Default)
-ifneq ($(strip $(PKG_UNPACK)),)
- define Build/Prepare/Default
- $(PKG_UNPACK)
- $(Build/Patch)
- $(if $(QUILT),touch $(PKG_BUILD_DIR)/.quilt_used)
+Host/Patch:=$(Host/Patch/Default)
+ifneq ($(strip $(HOST_UNPACK)),)
+ define Host/Prepare/Default
+ $(HOST_UNPACK)
+ $(Host/Patch)
+ $(if $(QUILT),touch $(HOST_BUILD_DIR)/.quilt_used)
endef
endif
-define Build/Prepare
- $(call Build/Prepare/Default)
+define Host/Prepare
+ $(call Host/Prepare/Default)
endef
-define Build/Configure/Default
- @(cd $(PKG_BUILD_DIR)/$(3); \
+define Host/Configure/Default
+ @(cd $(HOST_BUILD_DIR)/$(3); \
[ -x configure ] && \
- $(CP) $(SCRIPT_DIR)/config.{guess,sub} $(PKG_BUILD_DIR)/$(3)/ && \
+ $(CP) $(SCRIPT_DIR)/config.{guess,sub} $(HOST_BUILD_DIR)/$(3)/ && \
$(2) \
CPPFLAGS="$(HOST_CFLAGS)" \
LDFLAGS="$(HOST_LDFLAGS)" \
@@ -59,22 +59,22 @@ define Build/Configure/Default
)
endef
-define Build/Configure
- $(call Build/Configure/Default)
+define Host/Configure
+ $(call Host/Configure/Default)
endef
-define Build/Compile/Default
- $(MAKE) -C $(PKG_BUILD_DIR) $(1)
+define Host/Compile/Default
+ $(MAKE) -C $(HOST_BUILD_DIR) $(1)
endef
-define Build/Compile
- $(call Build/Compile/Default)
+define Host/Compile
+ $(call Host/Compile/Default)
endef
ifneq ($(if $(QUILT),,$(CONFIG_AUTOREBUILD)),)
- define HostBuild/Autoclean
- $(call rdep,${CURDIR} $(PKG_FILE_DEPEND),$(STAMP_PREPARED))
- $(if $(if $(Build/Compile),$(filter prepare,$(MAKECMDGOALS)),1),,$(call rdep,$(PKG_BUILD_DIR),$(STAMP_BUILT)))
+ define HostHost/Autoclean
+ $(call rdep,${CURDIR} $(PKG_FILE_DEPEND),$(HOST_STAMP_PREPARED))
+ $(if $(if $(Host/Compile),$(filter prepare,$(MAKECMDGOALS)),1),,$(call rdep,$(HOST_BUILD_DIR),$(HOST_STAMP_BUILT)))
endef
endif
@@ -88,45 +88,45 @@ define Download/default
endef
define HostBuild
- $(if $(QUILT),$(Build/Quilt))
+ $(if $(QUILT),$(Host/Quilt))
$(if $(strip $(PKG_SOURCE_URL)),$(call Download,default))
- $(if $(DUMP),,$(call HostBuild/Autoclean))
+ $(if $(DUMP),,$(call HostHost/Autoclean))
- $(STAMP_PREPARED):
- @-rm -rf $(PKG_BUILD_DIR)
- @mkdir -p $(PKG_BUILD_DIR)
- $(call Build/Prepare)
+ $(HOST_STAMP_PREPARED):
+ @-rm -rf $(HOST_BUILD_DIR)
+ @mkdir -p $(HOST_BUILD_DIR)
+ $(call Host/Prepare)
touch $$@
- $(STAMP_CONFIGURED): $(STAMP_PREPARED)
- $(call Build/Configure)
+ $(HOST_STAMP_CONFIGURED): $(HOST_STAMP_PREPARED)
+ $(call Host/Configure)
touch $$@
- $(STAMP_BUILT): $(STAMP_CONFIGURED)
- $(call Build/Compile)
+ $(HOST_STAMP_BUILT): $(HOST_STAMP_CONFIGURED)
+ $(call Host/Compile)
touch $$@
- $(STAMP_INSTALLED): $(STAMP_BUILT)
- $(call Build/Install)
+ $(HOST_STAMP_INSTALLED): $(HOST_STAMP_BUILT)
+ $(call Host/Install)
mkdir -p $$(shell dirname $$@)
touch $$@
- ifdef Build/Install
- install: $(STAMP_INSTALLED)
+ ifdef Host/Install
+ install: $(HOST_STAMP_INSTALLED)
endif
package-clean: FORCE
- $(call Build/Clean)
- $(call Build/Uninstall)
- rm -f $(STAMP_INSTALLED) $(STAMP_BUILT)
+ $(call Host/Clean)
+ $(call Host/Uninstall)
+ rm -f $(HOST_STAMP_INSTALLED) $(HOST_STAMP_BUILT)
download:
- prepare: $(STAMP_PREPARED)
- configure: $(STAMP_CONFIGURED)
- compile: $(STAMP_BUILT)
+ prepare: $(HOST_STAMP_PREPARED)
+ configure: $(HOST_STAMP_CONFIGURED)
+ compile: $(HOST_STAMP_BUILT)
install:
clean: FORCE
- $(call Build/Clean)
- rm -rf $(PKG_BUILD_DIR)
+ $(call Host/Clean)
+ rm -rf $(HOST_BUILD_DIR)
endef
diff --git a/include/quilt.mk b/include/quilt.mk
index fb8efacaa7..358b64ba0a 100644
--- a/include/quilt.mk
+++ b/include/quilt.mk
@@ -25,47 +25,65 @@ sed -e s,\\\#.*,, $(1) | grep -E \[a-zA-Z0-9\]
endef
define PatchDir/Quilt
- @if [ -s $(1)/series ]; then \
- mkdir -p $(PKG_BUILD_DIR)/patches/$(2); \
- cp $(1)/series $(PKG_BUILD_DIR)/patches/$(2); \
+ @if [ -s "$(2)/series" ]; then \
+ mkdir -p "$(1)/patches/$(3)"; \
+ cp "$(2)/series" "$(1)/patches/$(3)"; \
fi
- @for patch in $$$$( (cd $(1) && if [ -f series ]; then $(call filter_series,series); else ls; fi; ) 2>/dev/null ); do ( \
- cp "$(1)/$$$$patch" $(PKG_BUILD_DIR); \
- cd $(PKG_BUILD_DIR); \
- $(QUILT_CMD) import -P$(2)$$$$patch -p 1 "$$$$patch"; \
+ @for patch in $$$$( (cd "$(2)" && if [ -f series ]; then $(call filter_series,series); else ls; fi; ) 2>/dev/null ); do ( \
+ cp "$(2)/$$$$patch" "$(1)"; \
+ cd "$(1)"; \
+ $(QUILT_CMD) import -P$(3)$$$$patch -p 1 "$$$$patch"; \
$(QUILT_CMD) push -f >/dev/null 2>/dev/null; \
rm -f "$$$$patch"; \
); done
- $(if $(2),@echo $(2) >> $(PKG_BUILD_DIR)/patches/.subdirs)
+ $(if $(3),@echo $(3) >> "$(1)/patches/.subdirs")
endef
define PatchDir/Default
- @if [ -d "$(1)" -a "$$$$(ls $(1) | wc -l)" -gt 0 ]; then \
- if [ -s "$(1)/series" ]; then \
- $(call filter_series,$(1)/series) | xargs -n1 \
- $(PATCH) $(PKG_BUILD_DIR) "$(1)"; \
+ @if [ -d "$(2)" -a "$$$$(ls $(2) | wc -l)" -gt 0 ]; then \
+ if [ -s "$(2)/series" ]; then \
+ $(call filter_series,$(2)/series) | xargs -n1 \
+ $(PATCH) "$(1)" "$(2)"; \
else \
- $(PATCH) $(PKG_BUILD_DIR) "$(1)"; \
+ $(PATCH) "$(1)" "$(2)"; \
fi; \
fi
endef
define PatchDir
-$(call PatchDir/$(if $(strip $(QUILT)),Quilt,Default),$(strip $(1)),$(strip $(2)))
+$(call PatchDir/$(if $(strip $(QUILT)),Quilt,Default),$(strip $(1)),$(strip $(2)),$(strip $(3)))
endef
-QUILT?=$(strip $(shell test -f $(PKG_BUILD_DIR)/.quilt_used && echo y))
-ifneq ($(QUILT),)
- STAMP_PATCHED:=$(PKG_BUILD_DIR)/.quilt_patched
- STAMP_CHECKED:=$(PKG_BUILD_DIR)/.quilt_checked
- override CONFIG_AUTOREBUILD=
- prepare: $(STAMP_PATCHED)
- quilt-check: $(STAMP_CHECKED)
+ifneq ($(PKG_BUILD_DIR),)
+ QUILT?=$(strip $(shell test -f $(PKG_BUILD_DIR)/.quilt_used && echo y))
+ ifneq ($(QUILT),)
+ STAMP_PATCHED:=$(PKG_BUILD_DIR)/.quilt_patched
+ STAMP_CHECKED:=$(PKG_BUILD_DIR)/.quilt_checked
+ override CONFIG_AUTOREBUILD=
+ prepare: $(STAMP_PATCHED)
+ quilt-check: $(STAMP_CHECKED)
+ endif
endif
+ifneq ($(HOST_BUILD_DIR),)
+ HOST_QUILT?=$(strip $(shell test -f $(if $(PKG_BUILD_DIR),$(PKG_BUILD_DIR),$(HOST_BUILD_DIR))/.quilt_used && echo y))
+ ifneq ($(HOST_QUILT),)
+ HOST_STAMP_PATCHED:=$(HOST_BUILD_DIR)/.quilt_patched
+ HOST_STAMP_CHECKED:=$(HOST_BUILD_DIR)/.quilt_checked
+ override CONFIG_AUTOREBUILD=
+ host-prepare: $(HOST_STAMP_PATCHED)
+ host-quilt-check: $(HOST_STAMP_CHECKED)
+ endif
+endif
+
+define Host/Patch/Default
+ $(if $(QUILT),rm -rf $(HOST_BUILD_DIR)/patches; mkdir -p $(HOST_BUILD_DIR)/patches)
+ $(call PatchDir,$(HOST_BUILD_DIR),$(PATCH_DIR),)
+endef
+
define Build/Patch/Default
$(if $(QUILT),rm -rf $(PKG_BUILD_DIR)/patches; mkdir -p $(PKG_BUILD_DIR)/patches)
- $(call PatchDir,$(PATCH_DIR),)
+ $(call PatchDir,$(PKG_BUILD_DIR),$(PATCH_DIR),)
endef
kernel_files=$(foreach fdir,$(GENERIC_FILES_DIR) $(FILES_DIR),$(fdir)/.)
@@ -73,22 +91,26 @@ define Kernel/Patch/Default
rm -rf $(PKG_BUILD_DIR)/patches; mkdir -p $(PKG_BUILD_DIR)/patches
$(if $(kernel_files),$(CP) $(kernel_files) $(LINUX_DIR)/)
find $(LINUX_DIR)/ -name \*.rej -or -name \*.orig | $(XARGS) rm -f
- $(call PatchDir,$(GENERIC_PATCH_DIR),generic/)
- $(call PatchDir,$(PATCH_DIR),platform/)
+ $(call PatchDir,$(PKG_BUILD_DIR),$(GENERIC_PATCH_DIR),generic/)
+ $(call PatchDir,$(PKG_BUILD_DIR),$(PATCH_DIR),platform/)
endef
define Quilt/RefreshDir
- mkdir -p $(1)
- -rm -f $(1)/* 2>/dev/null >/dev/null
+ mkdir -p $(2)
+ -rm -f $(2)/* 2>/dev/null >/dev/null
@( \
- for patch in $$$$($(if $(2),grep "^$(2)",cat) $(PKG_BUILD_DIR)/patches/series | awk '{print $$$$1}'); do \
- $(CP) -v "$(PKG_BUILD_DIR)/patches/$$$$patch" $(1); \
+ for patch in $$$$($(if $(3),grep "^$(3)",cat) $(PKG_BUILD_DIR)/patches/series | awk '{print $$$$1}'); do \
+ $(CP) -v "$(PKG_BUILD_DIR)/patches/$$$$patch" $(2); \
done; \
)
endef
+define Quilt/Refresh/Host
+ $(call Quilt/RefreshDir,$(HOST_BUILD_DIR),$(PATCH_DIR))
+endef
+
define Quilt/Refresh/Package
- $(call Quilt/RefreshDir,$(PATCH_DIR))
+ $(call Quilt/RefreshDir,$(PKG_BUILD_DIR),$(PATCH_DIR))
endef
define Quilt/Refresh/Kernel
@@ -96,18 +118,14 @@ define Quilt/Refresh/Kernel
echo "All kernel patches must start with either generic/ or platform/"; \
false; \
}
- $(call Quilt/RefreshDir,$(GENERIC_PATCH_DIR),generic/)
- $(call Quilt/RefreshDir,$(PATCH_DIR),platform/)
-endef
-
-define Quilt/Refresh
-$(if $(TARGET_BUILD),$(Quilt/Refresh/Kernel),$(Quilt/Refresh/Package))
+ $(call Quilt/RefreshDir,$(PKG_BUILD_DIR),$(GENERIC_PATCH_DIR),generic/)
+ $(call Quilt/RefreshDir,$(PKG_BUILD_DIR),$(PATCH_DIR),platform/)
endef
define Build/Quilt
- $(STAMP_PATCHED): $(STAMP_PREPARED)
+ $($(2)STAMP_PATCHED): $($(2)STAMP_PREPARED)
@( \
- cd $(PKG_BUILD_DIR)/patches; \
+ cd $(1)/patches; \
$(QUILT_CMD) pop -a -f >/dev/null 2>/dev/null; \
if [ -s ".subdirs" ]; then \
rm -f series; \
@@ -124,36 +142,47 @@ define Build/Quilt
find * -type f \! -name series | sort > series; \
fi; \
)
- touch $$@
-
- $(STAMP_CONFIGURED): $(STAMP_CHECKED) FORCE
- $(STAMP_CHECKED): $(STAMP_PATCHED)
- if [ -s "$(PKG_BUILD_DIR)/patches/series" ]; then (cd $(PKG_BUILD_DIR); if $(QUILT_CMD) next >/dev/null 2>&1; then $(QUILT_CMD) push -a; else $(QUILT_CMD) top >/dev/null 2>&1; fi); fi
- touch $$@
+ touch "$$@"
+
+ $($(2)STAMP_CONFIGURED): $($(2)STAMP_CHECKED) FORCE
+ $($(2)STAMP_CHECKED): $($(2)STAMP_PATCHED)
+ if [ -s "$(1)/patches/series" ]; then \
+ (cd "$(1)"; \
+ if $(QUILT_CMD) next >/dev/null 2>&1; then \
+ $(QUILT_CMD) push -a; \
+ else \
+ $(QUILT_CMD) top >/dev/null 2>&1; \
+ fi \
+ ); \
+ fi
+ touch "$$@"
- quilt-check: $(STAMP_PREPARED) FORCE
- @[ -f "$(PKG_BUILD_DIR)/.quilt_used" ] || { \
+ $(3)quilt-check: $($(2)STAMP_PREPARED) FORCE
+ @[ -f "$(1)/.quilt_used" ] || { \
echo "The source directory was not unpacked using quilt. Please rebuild with QUILT=1"; \
false; \
}
- @[ -f "$(PKG_BUILD_DIR)/patches/series" ] || { \
+ @[ -f "$(1)/patches/series" ] || { \
echo "The source directory contains no quilt patches."; \
false; \
}
- @[ -n "$$$$(ls $(PKG_BUILD_DIR)/patches/series)" -o "$$$$(cat $(PKG_BUILD_DIR)/patches/series | md5sum)" = "$$(sort $(PKG_BUILD_DIR)/patches/series | md5sum)" ] || { \
+ @[ -n "$$$$(ls $(1)/patches/series)" -o "$$$$(cat $(1)/patches/series | md5sum)" = "$$(sort $(1)/patches/series | md5sum)" ] || { \
echo "The patches are not sorted in the right order. Please fix."; \
false; \
}
- refresh: quilt-check
- @cd $(PKG_BUILD_DIR); $(QUILT_CMD) pop -a -f >/dev/null 2>/dev/null
- @cd $(PKG_BUILD_DIR); while $(QUILT_CMD) next 2>/dev/null >/dev/null && $(QUILT_CMD) push; do \
+ $(3)refresh: $(3)quilt-check
+ @cd "$(1)"; $(QUILT_CMD) pop -a -f >/dev/null 2>/dev/null
+ @cd "$(1)"; while $(QUILT_CMD) next 2>/dev/null >/dev/null && $(QUILT_CMD) push; do \
QUILT_DIFF_OPTS="-p" $(QUILT_CMD) refresh -p ab --no-index --no-timestamps; \
done; ! $(QUILT_CMD) next 2>/dev/null >/dev/null
- $(Quilt/Refresh)
+ $(Quilt/Refresh/$(4))
- update: quilt-check
- $(Quilt/Refresh)
+ $(3)update: $(3)quilt-check
+ $(Quilt/Refresh/$(4))
endef
+Build/Quilt=$(call Quilt/Template,$(PKG_BUILD_DIR),,,$(if $(TARGET_BUILD),Kernel,Package))
+Host/Quilt=$(call Quilt/Template,$(HOST_BUILD_DIR),HOST_,host-,Host)
+
endif
diff --git a/include/unpack.mk b/include/unpack.mk
index 9b68e5dea3..ddd5fd11fe 100644
--- a/include/unpack.mk
+++ b/include/unpack.mk
@@ -11,13 +11,13 @@ ifneq ($(HOST_OS),Linux)
else
HOST_TAR:=$(TAR)
endif
-TAR_CMD:=$(HOST_TAR) -C $(PKG_BUILD_DIR)/.. $(TAR_OPTIONS)
-UNZIP_CMD:=unzip -d $(PKG_BUILD_DIR)/.. $(DL_DIR)/$(PKG_SOURCE)
+TAR_CMD=$(HOST_TAR) -C $(1)/.. $(TAR_OPTIONS)
+UNZIP_CMD=unzip -d $(1)/.. $(DL_DIR)/$(PKG_SOURCE)
ifeq ($(PKG_SOURCE),)
PKG_UNPACK ?= true
endif
-ifeq ($(strip $(PKG_UNPACK)),)
+ifeq ($(strip $(PKG_UNPACK))$(strip $(HOST_UNPACK)),)
ifeq ($(strip $(PKG_CAT)),)
# try to autodetect file type
EXT:=$(call ext,$(PKG_SOURCE))
@@ -25,40 +25,44 @@ ifeq ($(strip $(PKG_UNPACK)),)
ifeq ($(filter gz tgz,$(EXT)),$(EXT))
EXT:=$(call ext,$(PKG_SOURCE:.$(EXT)=))
- UNPACK:=gzip -dc $(DL_DIR)/$(PKG_SOURCE) |
- endif
+ DECOMPRESS_CMD:=gzip -dc $(DL_DIR)/$(PKG_SOURCE) |
+ endif
ifeq ($(filter bzip2 bz2 bz tbz2 tbz,$(EXT)),$(EXT))
EXT:=$(call ext,$(PKG_SOURCE:.$(EXT)=))
- UNPACK:=bzcat $(DL_DIR)/$(PKG_SOURCE) |
+ DECOMPRESS_CMD:=bzcat $(DL_DIR)/$(PKG_SOURCE) |
endif
ifeq ($(filter tgz tbz tbz2,$(EXT1)),$(EXT1))
EXT:=tar
endif
- UNPACK ?= cat $(DL_DIR)/$(PKG_SOURCE) |
+ DECOMPRESS_CMD ?= cat $(DL_DIR)/$(PKG_SOURCE) |
ifeq ($(EXT),tar)
- PKG_UNPACK:=$(UNPACK) $(TAR_CMD)
+ UNPACK_CMD=$(DECOMPRESS_CMD) $(TAR_CMD)
endif
ifeq ($(EXT),cpio)
- PKG_UNPACK:=$(UNPACK) (cd $(PKG_BUILD_DIR)/..; cpio -i -d)
+ UNPACK_CMD=$(DECOMPRESS_CMD) (cd $(1)/..; cpio -i -d)
endif
ifeq ($(EXT),zip)
- PKG_UNPACK:=$(UNZIP_CMD)
+ UNPACK_CMD=$(UNZIP_CMD)
endif
endif
-
+
# compatibility code for packages that set PKG_CAT
- ifeq ($(strip $(PKG_UNPACK)),)
+ ifeq ($(strip $(UNPACK_CMD)),)
# use existing PKG_CAT
- PKG_UNPACK:=$(PKG_CAT) $(DL_DIR)/$(PKG_SOURCE) | $(TAR_CMD)
+ UNPACK_CMD=$(PKG_CAT) $(DL_DIR)/$(PKG_SOURCE) | $(TAR_CMD)
ifeq ($(PKG_CAT),unzip)
- PKG_UNPACK:=$(UNZIP_CMD)
+ UNPACK_CMD=$(UNZIP_CMD)
endif
# replace zcat with $(ZCAT), because some system don't support it properly
ifeq ($(PKG_CAT),zcat)
- PKG_UNPACK:=gzip -dc $(DL_DIR)/$(PKG_SOURCE) | $(TAR_CMD)
+ UNPACK_CMD=gzip -dc $(DL_DIR)/$(PKG_SOURCE) | $(TAR_CMD)
endif
endif
ifneq ($(strip $(CRLF_WORKAROUND)),)
- PKG_UNPACK += && find $(PKG_BUILD_DIR) -type f -print0 | xargs -0 perl -pi -e 's!\r$$$$!!g'
+ CRLF_CMD := && find $(PKG_BUILD_DIR) -type f -print0 | xargs -0 perl -pi -e 's!\r$$$$!!g'
+ else
+ CRLF_CMD :=
endif
+ PKG_UNPACK := $(call UNPACK_CMD,$(PKG_BUILD_DIR)) $(call CRLF_CMD,$(PKG_BUILD_DIR))
+ HOST_UNPACK := $(call UNPACK_CMD,$(HOST_BUILD_DIR)) $(call CRLF_CMD,$(HOST_BUILD_DIR))
endif